Opened 4 years ago

Closed 4 years ago

#20491 closed defect (fixed)

WeightedIntegerVector returns vectors of rationals, not integers

Reported by: cnassau Owned by:
Priority: major Milestone: sage-7.2
Component: combinatorics Keywords: steenrod algebra
Cc: jhpalmieri Merged in:
Authors: John Palmieri Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 5ef16eb (Commits) Commit: 5ef16eb6e727624b93edf5879022fb32f27b0785
Dependencies: Stopgaps:

Description (last modified by jhpalmieri)

The following regression seems to be new in Sage7.2.beta5:

sage: for x in WeightedIntegerVectors(1, [1]): print type(x[0])
<type 'sage.rings.rational.Rational'>

Change History (8)

comment:1 Changed 4 years ago by cnassau

  • Component changed from PLEASE CHANGE to algebraic topology
  • Type changed from PLEASE CHANGE to defect

comment:2 Changed 4 years ago by jhpalmieri

  • Component changed from algebraic topology to combinatorics
  • Description modified (diff)
  • Summary changed from steenrod_algebra_basis exponents now rational, not integer to WeightedIntegerVector returns vectors of rationals, not integers

I think this happens in WeightedIntegerVectors. I've changed the ticket description accordingly.

comment:3 Changed 4 years ago by jhpalmieri

I think that this is caused by #20166.

comment:4 Changed 4 years ago by tscrim

It is probably this line

yield [n / l[0]]

in iterator_fast(); should be

yield [n // l[0]]

comment:5 Changed 4 years ago by jhpalmieri

  • Branch set to u/jhpalmieri/integer_vectors

comment:6 Changed 4 years ago by jhpalmieri

  • Authors set to John Palmieri
  • Commit set to 5ef16eb6e727624b93edf5879022fb32f27b0785
  • Status changed from new to needs_review

New commits:

5ef16ebtrac 20491: WeightedIntegerVectors should return vectors of integers,

comment:7 Changed 4 years ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

LGTM. Sorry for the trouble.

comment:8 Changed 4 years ago by vbraun

  • Branch changed from u/jhpalmieri/integer_vectors to 5ef16eb6e727624b93edf5879022fb32f27b0785
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.