Opened 5 years ago

Closed 5 years ago

#20396 closed enhancement (duplicate)

Implement the invariant form for complex reflection groups

Reported by: stumpc5 Owned by:
Priority: major Milestone: sage-7.2
Component: combinatorics Keywords: complex reflection group, cartan matrix
Cc: tscrim, chapoton, nthiery, vripoll Merged in:
Authors: Christian Stump Reviewers:
Report Upstream: N/A Work issues:
Branch: u/stumpc5/20396 (Commits, GitHub, GitLab) Commit: def701588736edda81a86ddd1a9cbdbc849657be
Dependencies: #11187 Stopgaps:

Status badges

Description

Implements the invariant form for complex, non-real reflection groups.

The implementation currently uses the Reynolds operator in Lemma 1.3 in Lehrer-Taylor, but I am asking to follow the Cartan matrix in Chapter 1.6, as we have the Cartan matrix already available.

Change History (7)

comment:1 Changed 5 years ago by chapoton

  • Branch set to public/20396
  • Commit set to cf00014efb9370d9e27cb7ecbdaa0864bfacb205
  • Dependencies set to #11187

comment:2 Changed 5 years ago by git

  • Commit changed from cf00014efb9370d9e27cb7ecbdaa0864bfacb205 to 75e8d699b73bc78ecd3374eddf6a927dc2f653a2

Branch pushed to git repo; I updated commit sha1. New commits:

75e8d69trac #20396 first try at simpler implementation

comment:3 Changed 5 years ago by git

  • Commit changed from 75e8d699b73bc78ecd3374eddf6a927dc2f653a2 to cdef4c3e7d25a51386265d03b41446ce8ee7db7a

Branch pushed to git repo; I updated commit sha1. New commits:

cdef4c3trac #20396 not yet working

comment:4 Changed 5 years ago by stumpc5

  • Branch changed from public/20396 to u/stumpc5/20396
  • Commit changed from cdef4c3e7d25a51386265d03b41446ce8ee7db7a to e02cf020c403d95a1d621c27b0af74295d2b84f0

Last 10 new commits:

844f450Merge branch 'u/stumpc5/11187' of trac.sagemath.org:sage into u/tscrim/reflection_groups-11187
d425669Fixing failures and some other things.
87cd989fixed one doctest in category complex reflection group
05a8ab411187: fixed trivial doctest failures
32bf1ae11187: cleanup of the organization of the various axioms (WellGenerated, ...) for complex/generalized reflection groups + documentation improvements
73276caMerge branch 'u/tscrim/11187' of trac.sagemath.org:sage into t/11187/11187
e074050merged
b572c74fixed a missing doctest
8013693Merge branch 'public/20396' of git://trac.sagemath.org/sage into u/stumpc5/20396
e02cf02still in trouble about the complex case

comment:5 Changed 5 years ago by git

  • Commit changed from e02cf020c403d95a1d621c27b0af74295d2b84f0 to def701588736edda81a86ddd1a9cbdbc849657be

Branch pushed to git repo; I updated commit sha1. Last 10 new commits:

bf2ea92fixed the coroots + work on invariant form
241e66011187: sum -> ZZ.sum for consistency when the list of degrees is empty
82ff28811187: rename 'reflecting hyperplane' to 'reflection hyperplane' in the docstrings
c09cd4d11187: Fixed heisenbug caused by temporarily breaking the implementation of (co)degrees for testing without restoring it after
0becba3Merge branch 'public/11187' of git://trac.sagemath.org/sage into u/stumpc5/20396
8927ab9matrix action is on the right!
eb2ea75cleaned the reduced word code
6fbba18undo the change to repr methods
8497f5dfirst try to skip elements in the iteration, too slow
def7015reorganized the invariant form (still missing an improvement) + fixed two doctests

comment:6 Changed 5 years ago by stumpc5

I merged the implementation as is into #11187 since it does work properly in the real case (using the Cartan matrix) and in the complex case (using brute force).

I would then use this ticket to figure how to do the Cartan matrix version in the complex case.

comment:7 Changed 5 years ago by stumpc5

  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from PLEASE CHANGE to enhancement

I now added the complete universal algorithm in all types (including non-irreducible and badly generated) and merged it into #11187.

Note: See TracTickets for help on using tickets.