Opened 4 years ago

Last modified 3 years ago

#20393 new enhancement

GAP3 package experimental -> optional

Reported by: stumpc5 Owned by:
Priority: major Milestone: sage-7.2
Component: interfaces: optional Keywords: gap3, optional package
Cc: tscrim, chapoton, nthiery, vripoll Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The GAP3 package #20107 is experimental because there is a problem with pexpect, and it also breaks several doctests in

  • src/sage/interfaces/gap3.py
  • src/sage/combinat/root_system/coxeter_group.py

Change History (4)

comment:1 Changed 4 years ago by stumpc5

  • Component changed from PLEASE CHANGE to interfaces: optional

comment:2 Changed 4 years ago by vripoll

  • Cc vripoll added

comment:3 Changed 3 years ago by dimpase

gap3 package does not work on 7.3.beta5:

...
[gap3-jm5-2015-02-01] INSTALL_DIR = /home/dima/software/sage/local/gap3/gap-jm5-2015-02-01
[gap3-jm5-2015-02-01] Applying patches...
[gap3-jm5-2015-02-01] can't find file to patch at input line 11
[gap3-jm5-2015-02-01] Perhaps you used the wrong -p or --strip option?
[gap3-jm5-2015-02-01] The text leading up to this was:
[gap3-jm5-2015-02-01] --------------------------
[gap3-jm5-2015-02-01] |Commenting out the optional packages
[gap3-jm5-2015-02-01] |RequirePackage("arep");
[gap3-jm5-2015-02-01] |RequirePackage("meataxe");
[gap3-jm5-2015-02-01] |RequirePackage("nq");
[gap3-jm5-2015-02-01] |RequirePackage("sisyphos");
[gap3-jm5-2015-02-01] |RequirePackage("ve");
[gap3-jm5-2015-02-01] |
[gap3-jm5-2015-02-01] |diff -ur src/gap3/lib/init.g.orig src/gap3/lib/init.g
[gap3-jm5-2015-02-01] |--- src/gap3/lib/init.g.orig	2016-03-30 17:58:09.557517250 +0200
[gap3-jm5-2015-02-01] |+++ src/gap3/lib/init.g	2016-03-30 17:58:23.265517363 +0200
[gap3-jm5-2015-02-01] --------------------------
[gap3-jm5-2015-02-01] File to patch: 
[gap3-jm5-2015-02-01] Skip this patch? [y] 
[gap3-jm5-2015-02-01] Skipping patch.
[gap3-jm5-2015-02-01] 1 out of 1 hunk ignored
[gap3-jm5-2015-02-01] Error applying 'patches/gap3_init.patch'
[gap3-jm5-2015-02-01] 
[gap3-jm5-2015-02-01] real	0m0.004s
[gap3-jm5-2015-02-01] user	0m0.001s
[gap3-jm5-2015-02-01] sys	0m0.003s
[gap3-jm5-2015-02-01] ************************************************************************
[gap3-jm5-2015-02-01] Error installing package gap3-jm5-2015-02-01
...

probably the install directory names have changed? After this error I don't have a directory SAGE_LOCAL/gap3/ at all...

comment:4 Changed 3 years ago by stumpc5

gap3 package does not work on 7.3.beta5

thanks for the report, I will try to look at is asap.

Note: See TracTickets for help on using tickets.