Opened 4 years ago

Closed 2 years ago

#20377 closed task (duplicate)

Minimize use of is_package_installed at runtime

Reported by: fbissey Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords: sagedays 77
Cc: slelievre Merged in:
Authors: François Bissey Reviewers:
Report Upstream: N/A Work issues:
Branch: u/fbissey/is_pkg_installed (Commits) Commit: aba00ce5414227f4d1a2fb9fcb7af8ba8d81ea6b
Dependencies: Stopgaps:

Description (last modified by slelievre)

This is helpful for sage-on-distributions. Typically sage-on-distribution do not want, or need, to call sage's internal packaging system.

I raised this as part of Sage days 77.

Related tickets:

  • #20382 Replace is_package_installed with Features
  • #21289 Don't use is_package_installed('bliss')
  • #21291 speed regression in is_package_installed
  • #21355 Timeout in graphs/tutte_polynomial.py

Change History (15)

comment:1 Changed 4 years ago by fbissey

  • Status changed from new to needs_review

comment:2 Changed 4 years ago by mmezzarobba

  • Component changed from PLEASE CHANGE to packages: optional

Your branch points to the latest beta, did you forget to push or something?

comment:3 Changed 4 years ago by jdemeyer

  • Status changed from needs_review to needs_work

comment:4 Changed 4 years ago by fbissey

I forgot to commit :(

comment:5 Changed 4 years ago by git

  • Commit changed from 7ffcdd1d2fa4cd1b8d7557cc1de7701b8692e18b to a8e208712c611396a6f3a80f326fd20468f1b03b

Branch pushed to git repo; I updated commit sha1. New commits:

a8e2087first draft of minimizing is_package_installed

comment:6 Changed 4 years ago by fbissey

  • Status changed from needs_work to needs_review

comment:7 Changed 4 years ago by vdelecroix

  • Status changed from needs_review to needs_work

You forget a colon

  File "/home/worker/sage-patchbot/local/lib/python2.7/site-packages/sage/groups/generic.py", line 1407
    if not os.path.isfile(os.path.join(SAGE_LOCAL, "gap", "latest", "small", "readsml.g"))

comment:8 Changed 4 years ago by git

  • Commit changed from a8e208712c611396a6f3a80f326fd20468f1b03b to d7d84834331724874a3798541cf16d9aae64f123

Branch pushed to git repo; I updated commit sha1. New commits:

d7d8483Add forgotten ":"

comment:9 Changed 4 years ago by fbissey

If that's all I forgot that's not a bad score. This particular one was different in sage-on-gentoo because I don't ship this database separately from gap like it is done in sage so it doesn't need testing. I'll still need to patch that one one way or another because the path will be different on gentoo. Alternative proposal welcome.

comment:10 Changed 4 years ago by git

  • Commit changed from d7d84834331724874a3798541cf16d9aae64f123 to aba00ce5414227f4d1a2fb9fcb7af8ba8d81ea6b

Branch pushed to git repo; I updated commit sha1. New commits:

aba00ceMerge branch 'develop' into is_pkg_installed

comment:11 Changed 4 years ago by saraedum

It seems we are working on the same issue ;) #20382 does essentially the same, maybe you want to have a look.

It seems to me that my approach is slightly more generic but I am open for discussion.

Last edited 4 years ago by saraedum (previous) (diff)

comment:12 Changed 4 years ago by slelievre

  • Cc slelievre added
  • Description modified (diff)
  • Summary changed from minimizing the use of is_package_install at runtime to Minimize use of is_package_installed at runtime

comment:13 follow-up: Changed 2 years ago by jdemeyer

Is this still relevant or should it be closed in the light of #20382?

comment:14 in reply to: ↑ 13 Changed 2 years ago by fbissey

  • Milestone changed from sage-7.2 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to needs_review

Replying to jdemeyer:

Is this still relevant or should it be closed in the light of #20382?

I think I should have marked this one duplicate months ago. There is nothing in here that #20382 doesn't do better.

comment:15 Changed 2 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.