Opened 3 years ago

Closed 20 months ago

#20316 closed enhancement (wontfix)

Add button to export SageNB notebooks to Jupyter

Reported by: iandrus Owned by: iandrus
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: user interface Keywords: mac app
Cc: kcrisman, slelievre Merged in:
Authors: Reviewers: Ivan Andrus
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #19877, #19881 Stopgaps:

Description

Once #19877 is done, then we can add a button to help the user export them.

Change History (12)

comment:1 Changed 3 years ago by kcrisman

  • Cc kcrisman added

comment:2 Changed 2 years ago by slelievre

  • Cc slelievre added

ping

comment:3 Changed 2 years ago by jdemeyer

What is this ticket about?

A button within SageNB to export the current worksheet as ipynb?

comment:4 Changed 2 years ago by kcrisman

This is to put a button specifically in the Mac app which does this (perhaps for all worksheets, perhaps for one?).

comment:5 Changed 2 years ago by jdemeyer

Why only the Mac app? Why not SageNB?

comment:6 Changed 2 years ago by kcrisman

No reason, that would just be a different ticket, since the codebases for the two are quite separate.

comment:7 Changed 2 years ago by kcrisman

So now that the sagenb export is available and #19881 is there, time to figure this out. I need to test #19881 functionality.

comment:8 Changed 23 months ago by kcrisman

I think this is still necessary despite the opening message, because if you start the SageNB server from the menu item it doesn't automatically show you that initial exporting message again. So unless someone decided to do this the very first time, they might not see that message again.

comment:9 Changed 22 months ago by iandrus

  • Milestone changed from sage-7.2 to sage-duplicate/invalid/wontfix

This is a duplicate of #22821.

comment:10 Changed 21 months ago by iandrus

  • Status changed from new to needs_review

comment:11 Changed 21 months ago by kcrisman

  • Authors Ivan Andrus deleted
  • Reviewers set to Ivan Andrus
  • Status changed from needs_review to positive_review

comment:12 Changed 20 months ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Closing tickets in the sage-duplicate/invalid/wontfix module with positive_review (i.e. someone has confirmed they should be closed).

Note: See TracTickets for help on using tickets.