Opened 4 years ago

Closed 19 months ago

#20180 closed defect (wontfix)

Bug: is_locally_represented_number_at_place returns incorrect value

Reported by: annahaensch Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: quadratic forms Keywords: bug
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Sorry this bug report is a bit ad hoc, but I suspect the thing that makes this buggy is part of a larger problem in the quadratic forms module. I'm running Sage 6.9 and I get the following in error if I construct the quadratic form

M=QuadraticForm(ZZ,3,[75,120,120,144,0,144])

then

sage: M.is_locally_represented_number_at_place(99,3)
False

and

sage: M.representation_number_list(100)[99]==0
False

But of course if I represent 99 over the integers, then I have to represent it locally. In this case the second output it correct, and the first one is incorrect. I think there is some underlying problem with the way global quadratic forms are defined.

Change History (6)

comment:1 Changed 2 years ago by annahaensch

  • Status changed from new to needs_review

This is a duplicate of #23412 and can be closed

comment:2 Changed 2 years ago by aly.deines

  • Status changed from needs_review to needs_work

comment:3 Changed 2 years ago by aly.deines

Hey, I don't know what happened, but I didn't change this.

comment:4 Changed 21 months ago by chapoton

  • Milestone changed from sage-7.1 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to needs_review

duplicate of #23412, please close

comment:5 Changed 21 months ago by chapoton

  • Status changed from needs_review to positive_review

comment:6 Changed 19 months ago by vdelecroix

  • Resolution set to wontfix
  • Status changed from positive_review to closed

closing positively reviewed duplicates

Note: See TracTickets for help on using tickets.