Opened 13 years ago

Closed 4 years ago

#1994 closed defect (wontfix)

cython spyx files -- cinclude, clib, issues

Reported by: was Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: user interface Keywords:
Cc: malb, robertwb Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by was)

There are some issues with cython spyx files:

  1. There is *still* nothing in the documentation anywhere in sage about cinclude, clib, etc. Here's a hint:
    Basically you put
    # clang c
    # clib  cblas
    # cfile myfile.c
    # cinclude "/usr/local/include"
    

Questions -- where can one put these? Must the # be there? However this is documented, at a bare minimum typing

sage: cython?
sage: load?
sage: attach?

should give enough information to find docs that clearly explain this cinclude, etc. directives.

  1. Create a file a.pxi and a file b.pyx. Put one of the # directives in the .pxi file and include the pxi file in the pyx file. The directive is ignored. This caused a ton of confusion today.

Change History (12)

comment:1 Changed 13 years ago by was

  • Description modified (diff)

comment:2 Changed 13 years ago by kedlaya

Is there also a directive ccflags (analogous to cflags in C)? For instance, in order to compile an spkg using FLINT, one needs a line like

#ccflags -std=c99

comment:3 Changed 13 years ago by mabshoff

  • Cc malb robertwb added

(1) should have been dealt via #3530, i.e. the documentation of the pragmas.

(2) is potentially still valid and I am not sure whose fault it is: Sage or Cython.

I am adding Martin and Robert to the CC field here.

Cheers,

Michael

comment:4 Changed 13 years ago by malb

Actually, (1) is not dealt with since it isn't necessarily easy to get to the new documentation. That should be addressed.

comment:5 Changed 9 years ago by kcrisman

  • Report Upstream set to N/A

Note that this stackoverflow.com post points to this ticket. Apparently this is still something that could be documented within Sage better?

comment:6 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:7 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:8 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:9 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:10 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Those directives should be deprecated anyway: #22461

comment:11 Changed 4 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:12 Changed 4 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Closing tickets in the sage-duplicate/invalid/wontfix module with positive_review (i.e. someone has confirmed they should be closed).

Note: See TracTickets for help on using tickets.