Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1992 closed defect (duplicate)

Loading and attaching spyx/pyx files -- automatic compilation and nsf locking

Reported by: was Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: user interface Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

When

 sage: load filename.spyx

is done repeatedly on a specific single file filename.spyx, after about 3-4 tries Sage tries to delete some files. On some NFS mounted filesystems, there are lock files, and these can't be deleted for permissions reasons. Instead of sage gracefully continuing on it fails at this point, and bombs out. This makes loading cython files fail henceforth, making spyx files completely useless.

The fix is probably just to put a try/except block around any code that deletes files that is related to attaching and loading [s]pyx files.

Change History (4)

comment:1 Changed 13 years ago by mabshoff

This is a dupe of #1559 - so which one should we close?

Cheers,

Michael

comment:2 Changed 13 years ago by was

closed as a dupe

comment:3 Changed 13 years ago by was

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.10.1 to sage-duplicate/invalid
Note: See TracTickets for help on using tickets.