Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#19911 closed defect (fixed)

Update to gap-4.8.3

Reported by: vbraun Owned by:
Priority: major Milestone: sage-7.2
Component: group theory Keywords:
Cc: dimpase, fbissey Merged in:
Authors: Dima Pasechnik, Volker Braun Reviewers: Dima Pasechnik, Volker Braun
Report Upstream: N/A Work issues:
Branch: ba471bc (Commits, GitHub, GitLab) Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by dimpase)

GAP 4.8.3 has been released, we got to get it into Sage.

Change History (43)

comment:1 Changed 6 years ago by jdemeyer

Duplicate of #19900?

comment:2 Changed 6 years ago by vbraun

  • Branch set to u/vbraun/update_to_gap_4_8_1

comment:3 Changed 6 years ago by git

  • Commit set to 3539c24f543901959a182a40666f578d1889f511

Branch pushed to git repo; I updated commit sha1. New commits:

3539c24Update libgap to 4.8.1

comment:4 Changed 6 years ago by git

  • Commit changed from 3539c24f543901959a182a40666f578d1889f511 to 949d4c2268e3b902d1044a31d4f58164e1dc6c2b

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

949d4c2Update libgap to 4.8.1

comment:5 Changed 6 years ago by git

  • Commit changed from 949d4c2268e3b902d1044a31d4f58164e1dc6c2b to b9842d48ed1278d4f54b87a7165f69b0fda4f1d2

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

b9842d4Update libgap to 4.8.1

comment:6 Changed 6 years ago by git

  • Commit changed from b9842d48ed1278d4f54b87a7165f69b0fda4f1d2 to 78586fa8efcd2268920657021187c1e8639c50ef

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

6f01e93Update libgap to 4.8.1
78586faUpdate libgap for ReadEvalCommand api change

comment:7 Changed 6 years ago by git

  • Commit changed from 78586fa8efcd2268920657021187c1e8639c50ef to c2fd7da68b78dc856fc4420d63b2f07118b14bf7

Branch pushed to git repo; I updated commit sha1. New commits:

c2fd7daUpdate gap ext code for changed rules for gap

comment:8 Changed 6 years ago by git

  • Commit changed from c2fd7da68b78dc856fc4420d63b2f07118b14bf7 to c1b5146397b91ec1e93b58eb59e4dd1d8d8bf219

Branch pushed to git repo; I updated commit sha1. New commits:

c1b5146Update sage code for changed rules for gap identifiers

comment:9 Changed 6 years ago by git

  • Commit changed from c1b5146397b91ec1e93b58eb59e4dd1d8d8bf219 to f409e06aa3817312f6efc73812bbd6d60e4a094e

Branch pushed to git repo; I updated commit sha1. New commits:

82af259Doctest fixes for changed subgroup generator choices
fc7a8d0Doctest fixes for changed GL(6,5) iteration order
f409e06Doctest fixes for changed presentation choice for semidirect product

comment:10 Changed 6 years ago by vbraun

  • Authors set to Dima Pasechnik, Volker Braun
  • Cc dimpase added
  • Component changed from PLEASE CHANGE to group theory
  • Description modified (diff)
  • Type changed from PLEASE CHANGE to defect

comment:11 Changed 6 years ago by vbraun

  • Status changed from new to needs_review

comment:12 Changed 6 years ago by dimpase

  • Status changed from needs_review to needs_work

lib gap does not build on OSX

...
duplicate symbol _libGAP_RealExecStatFuncs in:
    .libs/libgap_la-stats.o
    .libs/libgap_la-profile.o
ld: 1 duplicate symbol for architecture x86_64
collect2: error: ld returned 1 exit status
make[4]: *** [libgap.la] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all-recursive] Error 1
Error building libGAP.

comment:13 Changed 6 years ago by dimpase

In fact, it's not that we turn something static into public. These two things are duly present in the GAP source.

$ grep RealExecStatFuncs *
profile.c:UInt (* RealExecStatFuncs[256]) ( Stat stat );
profile.c:  RealExecStatFuncs[pos] = stat;
profile.c:  return RealExecStatFuncs[TNUM_STAT(stat)](stat);
profile.c:    ExecStatFuncs[i] = RealExecStatFuncs[i];
stats.c:UInt (* RealExecStatFuncs[256]) ( Stat stat );
stats.c:    ExecStatFuncs[i] = RealExecStatFuncs[i];
stats.c:            RealExecStatFuncs[i] = ExecStatFuncs[i];
Last edited 6 years ago by dimpase (previous) (diff)

comment:14 Changed 6 years ago by dimpase

comment:15 Changed 6 years ago by dimpase

  • Report Upstream changed from N/A to Reported upstream. Developers acknowledge bug.

comment:16 Changed 6 years ago by git

  • Commit changed from f409e06aa3817312f6efc73812bbd6d60e4a094e to c4c37d3aa19eee89c80f23ee27ff02e33e270612

Branch pushed to git repo; I updated commit sha1. New commits:

c4c37d3Fix symbol collision

comment:17 Changed 6 years ago by dimpase

  • Status changed from needs_work to positive_review

comment:18 Changed 6 years ago by vbraun

  • Milestone changed from sage-7.1 to sage-pending

comment:20 Changed 6 years ago by dimpase

Sure, and there will be 4.8.3 very soon (this month). I'd wait for it...

comment:21 Changed 6 years ago by dimpase

  • Description modified (diff)
  • Milestone changed from sage-pending to sage-7.2
  • Summary changed from Update to gap-4.8.1 to Update to gap-4.8.3

comment:22 follow-up: Changed 6 years ago by vbraun

  • Status changed from positive_review to needs_info

Do you have a branch for 4.8.3?

comment:23 in reply to: ↑ 22 Changed 6 years ago by dimpase

Replying to vbraun:

Do you have a branch for 4.8.3?

no

comment:24 Changed 6 years ago by git

  • Commit changed from c4c37d3aa19eee89c80f23ee27ff02e33e270612 to 5637feaf4f0ad4654dc572924acce593610fce66

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

6ebb699Update to gap-4.8.1
caca56cDelete gap tests that rely on small groups database
b32b693Update libgap to 4.8.1
cd395d3Update libgap for ReadEvalCommand api change
48b8bc6Update gap ext code for changed rules for gap
f53a2e6Update sage code for changed rules for gap identifiers
e4da4c1Doctest fixes for changed subgroup generator choices
776b9fbDoctest fixes for changed GL(6,5) iteration order
b8b01b0Doctest fixes for changed presentation choice for semidirect product
5637feaFix symbol collision

comment:25 Changed 6 years ago by git

  • Commit changed from 5637feaf4f0ad4654dc572924acce593610fce66 to d933a20f127340a8097357460119fbafcab5ae0d

Branch pushed to git repo; I updated commit sha1. New commits:

f4c2f65Update to gap-4.8.3
d933a20Update libgap to 4.8.3

comment:26 Changed 6 years ago by git

  • Commit changed from d933a20f127340a8097357460119fbafcab5ae0d to 0cec79e3624f8c8b7f7b6a82c512be155dcd8666

Branch pushed to git repo; I updated commit sha1. New commits:

0cec79eDoctest fixes for changed GL(6,5) iteration order

comment:27 Changed 6 years ago by vbraun

  • Status changed from needs_info to needs_review

comment:28 Changed 6 years ago by fbissey

  • Cc fbissey added

comment:29 Changed 6 years ago by dimpase

do you have the tarballs somewhere?

comment:30 Changed 6 years ago by vbraun

They are on the mirrors now

comment:31 Changed 6 years ago by dimpase

  • Status changed from needs_review to needs_work

gap_packages does not build, as guava version is now 3.13, its patches fail, probably need a review, etc.

comment:32 Changed 6 years ago by dimpase

  • Branch changed from u/vbraun/update_to_gap_4_8_1 to u/dimpase/gap483_update
  • Commit changed from 0cec79e3624f8c8b7f7b6a82c512be155dcd8666 to 789400c2d1f25f6ead5c724b50faf6f9b7ba995a
  • Status changed from needs_work to needs_review

here is the guava fix. works now, it seems


New commits:

8dab5eaMerge branch 'u/vbraun/update_to_gap_4_8_1' of git://trac.sagemath.org/sage into gap483
789400cbumped up guava version, removed patches (which are now upstream)

comment:33 Changed 6 years ago by dimpase

  • Status changed from needs_review to needs_work
  • Stopgaps set to Hap package is broken

ran ptestlong: got

sage -t --long --warn-long 71.3 src/sage/tests/gap_packages.py
**********************************************************************
File "src/sage/tests/gap_packages.py", line 8, in sage.tests.gap_packages
Failed example:
    test_packages(pkgs, only_failures=True)    # optional - gap_packages
Expected:
      Status    Package    GAP Output
    +---------+----------+------------+
      Failure   HAPcryst   fail
Got:
      Status    Package    GAP Output
    +---------+----------+------------+
      Failure   HAPcryst   fail
      Failure   Hap        fail
**********************************************************************

and

sage -t --long --warn-long 71.3 src/sage/groups/perm_gps/permgroup.py  # 19 doctests failed

all seemingly due to borked Hap.

comment:34 Changed 6 years ago by dimpase

The reason for Hap failing is that it depends on CrystCat in this release, and the latter in turn depends on Cryst.

These two are GAP-code only, thus trivial to add. Let me do this...

comment:35 Changed 6 years ago by vbraun

  • Branch changed from u/dimpase/gap483_update to u/vbraun/gap483_update

comment:36 Changed 6 years ago by vbraun

  • Branch changed from u/vbraun/gap483_update to u/dimpase/gap483_update

Oops hadn't realized you fixed it

comment:37 Changed 6 years ago by dimpase

  • Branch changed from u/dimpase/gap483_update to u/vbraun/gap483_update
  • Commit changed from 789400c2d1f25f6ead5c724b50faf6f9b7ba995a to 7bd659d88630cc1cf125afd412d940f161944c5a

and now gap_packages/spkg-src does not quite work, as cryst is prefix of crystcat :-)


New commits:

7bd659dRemove obsoleted patches with the guava-3.13 update

comment:38 Changed 6 years ago by dimpase

  • Branch changed from u/vbraun/gap483_update to u/dimpase/gap483_update
  • Commit changed from 7bd659d88630cc1cf125afd412d940f161944c5a to d90bafbcac1c693e8b6a2470d31752455d51910a
  • Report Upstream changed from Reported upstream. Developers acknowledge bug. to N/A
  • Status changed from needs_work to needs_review
  • Stopgaps Hap package is broken deleted

fixed tarball:

http://users.ox.ac.uk/~coml0531/sage/gap_packages-4.8.3.tar.bz2


New commits:

8dab5eaMerge branch 'u/vbraun/update_to_gap_4_8_1' of git://trac.sagemath.org/sage into gap483
789400cbumped up guava version, removed patches (which are now upstream)
2e14875added cryst, crystcat, aclib, happrime
d90bafbthis should go, too

comment:39 Changed 6 years ago by git

  • Commit changed from d90bafbcac1c693e8b6a2470d31752455d51910a to ba471bc94f054c201a6967c67fabe91b53db5a99

Branch pushed to git repo; I updated commit sha1. New commits:

ba471bcslight cleanup

comment:40 Changed 5 years ago by vbraun

  • Reviewers set to Dima Pasechnik, Volker Braun
  • Status changed from needs_review to positive_review

comment:41 Changed 5 years ago by vbraun

  • Branch changed from u/dimpase/gap483_update to ba471bc94f054c201a6967c67fabe91b53db5a99
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:42 Changed 5 years ago by fbissey

  • Commit ba471bc94f054c201a6967c67fabe91b53db5a99 deleted

Note for a follow up: atlasrep is in both database_gap and gap_packages may be we should decide one way or another which one it belongs too.

comment:43 Changed 5 years ago by fbissey

Oups, atlasrep is in database_gap's spkg-src but is not installed by its spkg-install. Definitely a follow up ticket.

Note: See TracTickets for help on using tickets.