Opened 3 years ago

Closed 3 years ago

#19794 closed defect (wontfix)

sage_mode uses SAGE_DATA

Reported by: vbraun Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: aschilling, jhpalmieri, jdemeyer Merged in:
Authors: Reviewers: Anne Schilling
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

SAGE_DATA was removed in sage-6.0

Sage-devel error report https://groups.google.com/d/msg/sage-devel/MrXp43v3WP4/lM5Kt238BAAJ

anne$ sage -p sage-mode
Found package sage-mode in /Applications/sage/upstream/sage-mode-0.6.spkg
sage-mode-0.6
====================================================
Extracting package /Applications/sage/upstream/sage-mode-0.6.spkg
-rw-r--r--  1 anne  admin  259682 Mar 18  2015 /Applications/sage/upstream/sage-mode-0.6.spkg
Finished extraction
****************************************************
Host system:
Darwin lolita.local 14.5.0 Darwin Kernel Version 14.5.0: Wed Jul 29 02:26:53 PDT 2015; root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64
****************************************************
C compiler: gcc
C compiler version:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/Applications/sage/local/libexec/gcc/x86_64-apple-darwin14.5.0/4.9.2/lto-wrapper
Target: x86_64-apple-darwin14.5.0
Configured with: ../src/configure --prefix=/Applications/sage/local --with-local-prefix=/Applications/sage/local --with-gmp=/Applications/sage/local --with-mpfr=/Applications/sage/local --with-mpc=/Applications/sage/local --with-system-zlib --disable-multilib --disable-nls --enable-languages=c,c++,fortran --disable-libitm --with-build-config=bootstrap-debug --without-isl --without-cloog  
Thread model: posix
gcc version 4.9.2 (GCC) 
****************************************************
running build
running build_py
creating build
creating build/lib
copying xreload.py -> build/lib
copying sage_emacs.py -> build/lib
running install
running build
running build_py
running install_lib
byte-compiling /Applications/sage/local/lib/python2.7/site-packages/sage_emacs.py to sage_emacs.pyc
byte-compiling /Applications/sage/local/lib/python2.7/site-packages/xreload.py to xreload.pyc
running install_egg_info
Removing /Applications/sage/local/lib/python2.7/site-packages/sage_mode-0.1-py2.7.egg-info
Writing /Applications/sage/local/lib/python2.7/site-packages/sage_mode-0.1-py2.7.egg-info
rm: /emacs: Permission denied

Change History (7)

comment:1 Changed 3 years ago by aschilling

  • Cc aschilling added

comment:2 Changed 3 years ago by mantepse

is there a difference between sage -i sage_mode and sage -i sage-mode? (I haven't got my computer with me right now, but sage-mode-0.6 looks ancient, see https://bitbucket.org/gvol/sage-mode/overview)

comment:3 follow-up: Changed 3 years ago by vbraun

  • Cc jhpalmieri jdemeyer added

Good point, sage -p sage-mode is the old-style spkg which you never want to install. I removed this particular ancient cruft once before since people trip over this on a weekly basis but then it was reverted in the name of backward compatibility. We deleted the old sage-mode.spkg from our servers but since you have a local copy it is used anyways.

comment:4 in reply to: ↑ 3 Changed 3 years ago by aschilling

Replying to vbraun:

Good point, sage -p sage-mode is the old-style spkg which you never want to install. I removed this particular ancient cruft once before since people trip over this on a weekly basis but then it was reverted in the name of backward compatibility. We deleted the old sage-mode.spkg from our servers but since you have a local copy it is used anyways.

Ok, thank you! sage -p sage_mode indeed worked fine! Sorry, I was not aware of this difference.

comment:5 Changed 3 years ago by vdelecroix

  • Milestone changed from sage-7.0 to sage-duplicate/invalid/wontfix
  • Reviewers set to Anne Schilling
  • Status changed from new to needs_review

This is just a misusage of Sage, not a bug of any kind (except the presence of the tarball on the repository that Volker fixed).

comment:6 Changed 3 years ago by vdelecroix

  • Status changed from needs_review to positive_review

comment:7 Changed 3 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Determined to be invalid/duplicate/wontfix (closing as "wontfix" as a catch-all resolution).

Note: See TracTickets for help on using tickets.