Opened 7 years ago

Closed 7 years ago

#19723 closed enhancement (fixed)

planarity: use newer version of config.guess

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-7.0
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Jeroen Demeyer Reviewers: François Bissey
Report Upstream: N/A Work issues:
Branch: d43b80a (Commits, GitHub, GitLab) Commit: d43b80abf41896403139f686b9ae92beec827c40
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

Upstream version 3.0.0.4 uses autotools, but has significant API changes, making it non-trivial to upgrade.

To allow building planarity 2.2.0 on recent systems, we simply copy over recent config.guess and config.sub files.

Change History (6)

comment:1 Changed 7 years ago by jdemeyer

Description: modified (diff)

comment:2 Changed 7 years ago by jdemeyer

Branch: u/jdemeyer/allow_planarity_to_compile_on_ppc64le

comment:3 Changed 7 years ago by jdemeyer

Commit: d43b80abf41896403139f686b9ae92beec827c40
Description: modified (diff)
Status: newneeds_review

New commits:

d43b80aplanarity: use newer version of config.guess and config.sub

comment:4 Changed 7 years ago by fbissey

Reviewers: François Bissey
Status: needs_reviewpositive_review

Trivial.

comment:5 Changed 7 years ago by jdemeyer

Summary: Allow planarity to compile on ppc64leplanarity: use newer version of config.guess

comment:6 Changed 7 years ago by vbraun

Branch: u/jdemeyer/allow_planarity_to_compile_on_ppc64led43b80abf41896403139f686b9ae92beec827c40
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.