Opened 4 years ago

Closed 4 years ago

#19715 closed defect (fixed)

ATLAS should skip "fast" configuration if it is not implemented

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-7.0
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Jeroen Demeyer Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: 939d37b (Commits) Commit: 939d37b1c24ce2eabf1dabf8d4a9591da34e1b30
Dependencies: Stopgaps:

Description

ATLAS should just skip the "fast" option if it is not available:

Third attempt: use "fast" options.
Traceback (most recent call last):
  File "./spkg-install", line 526, in <module>
    rc = build(arch='fast')
  File "./spkg-install", line 454, in build
    rc = configure(arch, isa_ext)
  File "./spkg-install", line 254, in configure
    arch, isa_ext, thread_limit = configure_fast()
  File "./spkg-install", line 374, in configure_fast
    raise NotImplementedError('I don\'t know a "fast" configuration for your cpu.')
NotImplementedError: I don't know a "fast" configuration for your cpu.

Change History (10)

comment:1 Changed 4 years ago by jdemeyer

  • Branch set to u/jdemeyer/atlas_should_skip__fast__configuration_if_it_is_not_implemented

comment:2 Changed 4 years ago by git

  • Commit set to 6aea3d36ae8cab6bcb3e9212aa8822983284036b

Branch pushed to git repo; I updated commit sha1. New commits:

6aea3d3Return rc instead of exiting when configure() fails

comment:3 Changed 4 years ago by jdemeyer

  • Status changed from new to needs_review

comment:4 Changed 4 years ago by jdemeyer

  • Status changed from needs_review to needs_work

comment:5 Changed 4 years ago by git

  • Commit changed from 6aea3d36ae8cab6bcb3e9212aa8822983284036b to 939d37b1c24ce2eabf1dabf8d4a9591da34e1b30

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

939d37bReturn rc instead of exiting when configure() fails

comment:6 Changed 4 years ago by jdemeyer

  • Status changed from needs_work to needs_review

comment:7 Changed 4 years ago by jpflori

If I remember correctly there is another issue with POWER8 and Atlas. Configuration (or tuning, who knows) fails because there are too many registers on POWER8 !!!

See http://sourceforge.net/p/math-atlas/bugs/225/ Oh it was POWER7 already actually.

comment:8 Changed 4 years ago by jdemeyer

I didn't have that problem. Either it's fixed or it occurs only on POWER7, not POWER8.

comment:9 Changed 4 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:10 Changed 4 years ago by vbraun

  • Branch changed from u/jdemeyer/atlas_should_skip__fast__configuration_if_it_is_not_implemented to 939d37b1c24ce2eabf1dabf8d4a9591da34e1b30
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.