Opened 5 years ago

Closed 4 years ago

#19701 closed task (fixed)

Port SageMath to Power8 ppc64le

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: u/jdemeyer/ticket/19701 (Commits, GitHub, GitLab) Commit: c19635ff199c0a7e4e4aa66c2c7c7ac1e9347884
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

Port SageMath to the ppc64le architecture (running on POWER8 processors).

  • #19702: Upgrade GNU patch
  • #19703: Update config.guess in bzip2
  • #19704: Build generic MPIR on ppc64le
  • #19705: Add ppc64le support to config.guess
  • #19708: Upgrade MPFR
  • #19709: Upgrade MPC
  • #19711: SQLite: use newer version of config.guess
  • #19713: GLPK: use newer version of config.guess
  • #19714: ZeroMQ: use newer version of config.guess
  • #19716: MPFI: use newer version of config.guess
  • #19717: Allow tachyon to install on ppc64le
  • #19718: cddlib: use newer version of config.guess
  • #19719: Upgrade ATLAS to version 3.11.38
  • #19720: Upgrade fplll
  • #19721: Create new libgd tarball
  • #19723: planarity: use newer version of config.guess
  • #19724: ECM: use newer version of config.guess
  • #19725: lrcalc: use newer version of config.guess
  • #19726: GAP: use newer version of config.guess
  • #19727: gf2x: use newer version of config.guess
  • #19728: givaro: use newer version of config.guess
  • #19729: Rename boehm_gc to gc and upgrade to latest upstream
  • #19731: Upgrade NTL
  • #19732: ECL: use newer version of config.guess
  • #19734: Maxima: use newer version of config.guess
  • #19754: Upgrade to GCC 4.9.3
  • #19757: fflas_ffpack: use newer version of config.guess
  • #19761: LinBox: use newer version of config.guess
  • #19765: Fix linking to FLINT
  • #19767: ATLAS drops LDFLAGS during build
  • #19793: Fix arb on ppc64le
  • #19805: Allow custom configure options for ATLAS
  • #19806: GSL: use newer version of config.guess
  • #19819: Update to pynac-0.6.0
  • #19845: Random failure in libGAP on ppc64le

Change History (61)

comment:1 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:2 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:3 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:4 Changed 5 years ago by jdemeyer

  • Description modified (diff)
  • Summary changed from Port SageMath to Power8 to Port SageMath to Power8 ppc64le

comment:5 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:6 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:7 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:8 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:9 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:10 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:11 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:12 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:13 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:14 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:15 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:16 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:17 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:18 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:19 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:20 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:21 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:22 Changed 5 years ago by jdemeyer

  • Branch set to u/jdemeyer/ticket/19701

comment:23 Changed 5 years ago by git

  • Commit set to efcfa2ae605a254d3e0759f8d0c9039c293b096d

Branch pushed to git repo; I updated commit sha1. New commits:

efcfa2aRevert "Upgrade fplll"

comment:24 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:25 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:26 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:27 Changed 5 years ago by jdemeyer

  • Branch u/jdemeyer/ticket/19701 deleted
  • Commit efcfa2ae605a254d3e0759f8d0c9039c293b096d deleted

comment:28 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:29 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:30 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:31 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:32 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:33 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:34 Changed 5 years ago by jdemeyer

  • Branch set to u/jdemeyer/ticket/19701

comment:35 Changed 5 years ago by git

  • Commit set to bbcf48d82deb68b67ec5e72479b7cc012b51cd91

Branch pushed to git repo; I updated commit sha1. New commits:

f9064c3Remove unnecessary patch
54ff55fUse LDFLAGS for linking libpari-gmp
bbcf48dMerge commit '54ff55f9f7569850caa4eb68ddc0aced74b72d44' into ticket/19701

comment:36 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:37 Changed 5 years ago by jdemeyer

This now works, modulo #19767 and the following doctest failures (which are probably due to GMP):

sage -t --long --warn-long 199.7 src/sage/interfaces/maxima.py  # 2 doctests failed
sage -t --long --warn-long 199.7 src/sage/structure/sage_object.pyx  # Killed due to abort
sage -t --long --warn-long 199.7 src/sage/symbolic/expression.pyx  # 1 doctest failed
sage -t --long --warn-long 199.7 src/sage/libs/libecm.pyx  # 1 doctest failed
sage -t --long --warn-long 199.7 src/doc/en/constructions/algebraic_geometry.rst  # 1 doctest failed
sage -t --long --warn-long 199.7 src/sage/ext/memory.pyx  # 1 doctest failed
sage -t --long --warn-long 199.7 src/sage/rings/real_arb.pyx  # Killed due to abort

comment:38 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:39 Changed 5 years ago by git

  • Commit changed from bbcf48d82deb68b67ec5e72479b7cc012b51cd91 to 0c31f9cb0decf3ce859137baebd9b710d2d679e1

Branch pushed to git repo; I updated commit sha1. New commits:

34b76d8fflas_ffpack: use newer version of config.guess and config.sub
ebc75e2Support LDFLAGS in ATLAS build
d87d848Support a generic MPIR on ppc64le
0c31f9cMerge commit '34b76d88b61ce501b55acf31b1eab75782bd4454'; commit 'ebc75e24c79af6e8184fd22980985bbd721106ee'; commit 'd87d84895e093208793d633a80b484327ce011c7' into t/19701/ticket/19701

comment:40 Changed 5 years ago by git

  • Commit changed from 0c31f9cb0decf3ce859137baebd9b710d2d679e1 to db7c23500fb135cedbb92d93d0ab7452f54e49df

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

db7c235Merge commit 'd87d84895e093208793d633a80b484327ce011c7'; commit '6ad1b3659bbcc16f5a4288deb6d47b6f19fea476'; commit 'ac53b646a9f3e3a289ba72c02342d528b96b93b7' into HEAD

comment:41 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:42 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:43 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:44 Changed 5 years ago by git

  • Commit changed from db7c23500fb135cedbb92d93d0ab7452f54e49df to dba6bef8f2873c36d3eaef3455b857ce716157fe

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

484b3c7Custom configure options for ATLAS using ATLAS_CONFIGURE
e02af81Merge
f21cc50Upgrade ATLAS to version 3.11.38
dba6befMerge commit 'f21cc5000fb2930ca2e8cff2bb90340489a73ee5' into t/19805/allow_custom_configure_options_for_atlas

comment:45 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:46 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:47 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:48 Changed 5 years ago by git

  • Commit changed from dba6bef8f2873c36d3eaef3455b857ce716157fe to 785eb0c26f663d1b112a5f1d2887ca2da249bbbd

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

e79da1fUpgrade ATLAS to version 3.11.38
939327carb: use variable names which do not conflict with FLINT
871763fGSL: use newer version of config.guess and config.sub
694feb2Build GSL in IEEE 754 compliant mode
785eb0cMerge commit '939327c15d8ebb237e2136954650a9634d2d99ba'; commit '484b3c71cc54f46f5dc920b441cb67dfab10f2f7'; commit '871763fe0949258d39da954c68ab631a46df27b8'; commit '694feb2d71ebf521cf5f32dba69e0406d16e9f11' into ticket/19701

comment:49 Changed 5 years ago by jdemeyer

First completely successful run of make ptestlong! There might still be non-reproducible failures though...

comment:50 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:51 Changed 5 years ago by jdemeyer

There is still some pexpect issue with GAP (random failures or timeouts).

comment:52 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:53 Changed 5 years ago by git

  • Commit changed from 785eb0c26f663d1b112a5f1d2887ca2da249bbbd to 31daf528d7d05a6f8c55dcfd7e6e6070d9c00742

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

2b42c76pynac-0.6.0 pkg version/chksum, symbolic interface, cot/acot, doctest changes
4bd89e6restore original doctest
26af24dMinor pynac fixes
ae48effDoctest fixes for 32-bit
5ea3457allow tol because of OSX difference
33a4faa19819: make beta function doctests order-independent
31daf52Merge commit 'e79da1ffebc490b2e6ced066290f735fc1f9d463'; commit '484b3c71cc54f46f5dc920b441cb67dfab10f2f7'; commit '33a4faab1ff70d2d3b2f0d3f61248a61bae57149' into t/19701/ticket/19701

comment:54 Changed 5 years ago by jdemeyer

Random failure:

sage -t --long --warn-long 101.9 src/sage/combinat/integer_vectors_mod_permgroup.py
**********************************************************************
File "src/sage/combinat/integer_vectors_mod_permgroup.py", line 169, in sage.combinat.integer_vectors_mod_permgroup.IntegerVectorsModPermutationGroup
Failed example:
    for i in range(10): # long time
          d1 = I.subset(i).cardinality()
          d2 = Partitions(i, max_length=5).cardinality()
          print d1
          assert d1 == d2
Exception raised:
    Traceback (most recent call last):
      File "/home/jdemeyer/sage7b3/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 496, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/home/jdemeyer/sage7b3/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 858, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.combinat.integer_vectors_mod_permgroup.IntegerVectorsModPermutationGroup[25]>", line 2, in <module>
        d1 = I.subset(i).cardinality()
      File "/home/jdemeyer/sage7b3/local/lib/python2.7/site-packages/sage/combinat/integer_vectors_mod_permgroup.py", line 526, in subset
        return IntegerVectorsModPermutationGroup_with_constraints(self.permutation_group(), sum, max_part)
      File "sage/misc/classcall_metaclass.pyx", line 326, in sage.misc.classcall_metaclass.ClasscallMetaclass.__call__ (/home/jdemeyer/sage7b3/src/build/cythonized/sage
/misc/classcall_metaclass.c:1239)
        return cls.classcall(cls, *args, **kwds)
      File "sage/misc/cachefunc.pyx", line 973, in sage.misc.cachefunc.CachedFunction.__call__ (/home/jdemeyer/sage7b3/src/build/cythonized/sage/misc/cachefunc.c:5371)
        w = self.f(*args, **kwds)
      File "/home/jdemeyer/sage7b3/local/lib/python2.7/site-packages/sage/structure/unique_representation.py", line 1021, in __classcall__
        instance = typecall(cls, *args, **options)
      File "sage/misc/classcall_metaclass.pyx", line 493, in sage.misc.classcall_metaclass.typecall (/home/jdemeyer/sage7b3/src/build/cythonized/sage/misc/classcall_met
aclass.c:1665)
        return (<PyTypeObject*>type).tp_call(cls, args, kwds)
      File "/home/jdemeyer/sage7b3/local/lib/python2.7/site-packages/sage/combinat/integer_vectors_mod_permgroup.py", line 618, in __init__
        self._sgs = G.strong_generating_system()
      File "/home/jdemeyer/sage7b3/local/lib/python2.7/site-packages/sage/groups/perm_gps/permgroup.py", line 1477, in strong_generating_system
        sgs.append(stab.transversals(j))
      File "/home/jdemeyer/sage7b3/local/lib/python2.7/site-packages/sage/groups/perm_gps/permgroup.py", line 1274, in transversals
        for i in self.orbit(point)]
      File "/home/jdemeyer/sage7b3/local/lib/python2.7/site-packages/sage/groups/perm_gps/permgroup.py", line 662, in __call__
        return self._element_class()(x, self, check=check)
      File "sage/groups/perm_gps/permgroup_element.pyx", line 457, in sage.groups.perm_gps.permgroup_element.PermutationGroupElement.__init__ (/home/jdemeyer/sage7b3/sr
c/build/cythonized/sage/groups/perm_gps/permgroup_element.c:5135)
        raise TypeError, 'permutation %s not in %s'%(g, parent)
    TypeError: permutation (1,5) not in Symmetric group of order 5! as a permutation group

comment:55 Changed 5 years ago by jdemeyer

  • Description modified (diff)

comment:56 Changed 5 years ago by git

  • Commit changed from 31daf528d7d05a6f8c55dcfd7e6e6070d9c00742 to 2872a8018f1d83ba9f4fd4057294cc6612e6d47e

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

2872a80Upgrade ATLAS to version 3.11.38

comment:57 Changed 5 years ago by git

  • Commit changed from 2872a8018f1d83ba9f4fd4057294cc6612e6d47e to 13388a53dabb28bee4355360e4797f184b60a9a5

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

13388a5Upgrade ATLAS to version 3.11.38

comment:58 Changed 5 years ago by git

  • Commit changed from 13388a53dabb28bee4355360e4797f184b60a9a5 to c19635ff199c0a7e4e4aa66c2c7c7ac1e9347884

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

c19635fUpgrade ATLAS to version 3.11.38

comment:59 Changed 5 years ago by jpflori

Now that OpenBlas? replaced ATLAS maybe we're good?

comment:60 Changed 5 years ago by jdemeyer

Depends on #19845. I haven't looked at it for a while...

comment:61 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-7.0 to sage-duplicate/invalid/wontfix
  • Resolution set to fixed
  • Status changed from new to closed

I'm running a ppc64le patchbot "sardonis" and everything seems to work fine...

Note: See TracTickets for help on using tickets.