Opened 5 years ago

Closed 5 years ago

#19565 closed defect (fixed)

develop manual : use develop instead of master

Reported by: chapoton Owned by:
Priority: major Milestone: sage-6.10
Component: documentation Keywords:
Cc: Merged in:
Authors: Frédéric Chapoton Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: 517cca5 (Commits) Commit: 517cca5e0b2f6cad500f181ec599aac43d3dd085
Dependencies: Stopgaps:

Description

For people wanting to develop, one should tell them to use the develop branch.

Change History (13)

comment:1 Changed 5 years ago by chapoton

  • Authors set to Frédéric Chapoton
  • Branch set to public/19565
  • Commit set to 7c64d379def18303048c6d2c9b4a9aba42d046e6
  • Status changed from new to needs_review

New commits:

7c64d37trac #19565 a word on develop branch in develop manual

comment:2 Changed 5 years ago by tscrim

  • Reviewers set to Travis Scrimshaw

If you split the last line to lengths at most around 80 characters, then you can set a positive review on my behalf.

comment:3 Changed 5 years ago by git

  • Commit changed from 7c64d379def18303048c6d2c9b4a9aba42d046e6 to d52a6bf3dae91fb4f42be8ae7656844ae83c4c7e

Branch pushed to git repo; I updated commit sha1. New commits:

d52a6bftrac #19565 better doc for new developers

comment:4 Changed 5 years ago by jdemeyer

Elephant in the room: why is master != develop? I think the problem is not the documentation, the problem is the strange convention that Sage's master isn't actually what most projects call master.

comment:5 Changed 5 years ago by chapoton

Well.. I have seen that question raised already, but where ?

Now, today, I have a potential new user that is perplexed.

Last edited 5 years ago by chapoton (previous) (diff)

comment:6 follow-up: Changed 5 years ago by tscrim

What do other projects do for their latest beta branch versus stable release? I thought master was suppose to be used for stable versions. Granted, our beta versions are usually fairly stable, but even once in awhile, we do break things badly with beta versions...

Actually, a somewhat radical thought, what if we do make master somehow be the more granular bumps and not call them betas but, e.g., 6.10.4, and then we have a latest merged branch that Volker includes? This way we could stop with those "wait until next beta to deal with conflicts/problems" messages for closed tickets that Volker has already included but not released.

comment:7 in reply to: ↑ 6 Changed 5 years ago by jdemeyer

Replying to tscrim:

What do other projects do for their latest beta branch versus stable release? I thought master was suppose to be used for stable versions.

Not at all. master normally means the development version.

comment:8 Changed 5 years ago by etn40ff

A semi-standard way of doing things in github is to keep development happening in master and to use tags for releases. I guess this discussion is more suited for sage-devel though.

As for the content of the ticket, I will be glad to accommodate Travis request as soon as my sage install finishes a run of tests.

comment:9 Changed 5 years ago by git

  • Commit changed from d52a6bf3dae91fb4f42be8ae7656844ae83c4c7e to 517cca5e0b2f6cad500f181ec599aac43d3dd085

Branch pushed to git repo; I updated commit sha1. New commits:

517cca5Wrapped test to 80 columns

comment:10 Changed 5 years ago by etn40ff

Sorry for the stupid mistake in the commit message: test was meant to be text

comment:11 follow-up: Changed 5 years ago by vbraun

  • Status changed from needs_review to positive_review

The master/develop terminology is from git flow: http://nvie.com/posts/a-successful-git-branching-model/

comment:12 in reply to: ↑ 11 Changed 5 years ago by jdemeyer

Replying to vbraun:

The master/develop terminology is from git flow: http://nvie.com/posts/a-successful-git-branching-model/

Good to know that there is at least one other person using the same model as Sage :-)

comment:13 Changed 5 years ago by vbraun

  • Branch changed from public/19565 to 517cca5e0b2f6cad500f181ec599aac43d3dd085
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.