Opened 4 years ago

Closed 4 years ago

#19549 closed enhancement (fixed)

Get rid of libtool archives (*.la)

Reported by: vbraun Owned by:
Priority: major Milestone: sage-6.10
Component: build Keywords: sd70
Cc: fbissey Merged in:
Authors: Volker Braun Reviewers: François Bissey
Report Upstream: N/A Work issues:
Branch: dc6d482 (Commits) Commit: dc6d482122b25bd1e23cf78b7781a2c7314a1796
Dependencies: Stopgaps:

Description

  • They are a nuisance since they can't contain relative paths.
  • Fedora packaging guide line says "Libtool archives, foo.la files, should not be included"
  • the whole idea of Libtool Archives is, nowadays, considered obsolete (https://autotools.io/libtool/lafiles.html)
  • Anything that can be done with libtool archives can be done better with pkg-config

Change History (9)

comment:1 Changed 4 years ago by vbraun

  • Keywords sd70 added

comment:2 follow-up: Changed 4 years ago by vbraun

  • Cc fbissey added

Francois, any objection?

comment:3 in reply to: ↑ 2 Changed 4 years ago by fbissey

Replying to vbraun:

Francois, any objection?

None.

comment:4 Changed 4 years ago by fbissey

I am not sure what other answer you were expecting from me. Distros like Gentoo (and most others I would think) get rid of them. The good question is how to do it in sage? The easiest way would be for sage-spkg to do the scanning. We don't want it to be done as an afterthought once the sage build is finished.

The problem is that you don't have a staging phase before putting the file in your tree. So you cannot stage then remove the ugly stuff and then put it in your tree (or prefix if you will). Which means that essentially you may have to scan the whole $SAGE_LOCAL/lib for .la file after you have issued make install for every package. Could it be added to sage-spkg to do once spkg-install proper is finished? How would that interact with spkg-check is also something to think about because building test may rely on these .la files.

comment:5 Changed 4 years ago by vbraun

  • Branch set to u/vbraun/get_rid_of_libtool_archives

comment:6 Changed 4 years ago by git

  • Commit set to dc6d482122b25bd1e23cf78b7781a2c7314a1796

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

dc6d482Erase libtool archive files after running spkg-install

comment:7 Changed 4 years ago by vbraun

  • Authors set to Volker Braun
  • Status changed from new to needs_review

I'm just deleting them after spkg-check; Not sure if its necessary but can't hurt.

comment:8 Changed 4 years ago by fbissey

  • Reviewers set to François Bissey
  • Status changed from needs_review to positive_review

That'll do, it will depend on the package. In m4rie test are built during make all. Not really fantastic in my opinion but that's a case where it wouldn't be necessary.

comment:9 Changed 4 years ago by vbraun

  • Branch changed from u/vbraun/get_rid_of_libtool_archives to dc6d482122b25bd1e23cf78b7781a2c7314a1796
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.