Opened 14 years ago

Closed 14 years ago

#1939 closed defect (fixed)

[with patch] Fix OSX rpy import issues: DYLD_LIBRARY_PATH fix

Reported by: mabshoff Owned by: mabshoff
Priority: major Milestone: sage-2.10.1
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The latest r.spkg from

http://sage.math.washington.edu/home/mabshoff/release-cycles-2.10.1/rc0/r-2.6.1.p13.spkg

needs the attached patch to properly import libR.dylib. DYLD_LIBRARY_PATH is properly set, but from some reason import fails. By adding the R's lib directory to DY_LDLIBRARY_PATH in sage-env the issue is resolved.

Cheers,

Michael

Attachments (1)

Sage-2.10.1.rc0-fix-rpy-import-on-OSX.patch (785 bytes) - added by mabshoff 14 years ago.

Download all attachments as: .zip

Change History (2)

Changed 14 years ago by mabshoff

comment:1 Changed 14 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from new to closed

Merged in Sage 2.10.1.rc0

Note: See TracTickets for help on using tickets.