Opened 7 years ago

Last modified 7 years ago

#19298 closed enhancement

require C++11 in Sage — at Version 3

Reported by: Ralf Stephan Owned by:
Priority: major Milestone: sage-6.10
Component: build: configure Keywords:
Cc: Nathann Cohen, François Bissey Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Ralf Stephan)

Several packages need C++11 more or less urgently (e.g., pynac, Givaro-LinBox?-fflas-ffpack ecosystem, cryptominisat). They need different subsets of C++11. The first full featured C++11 gcc version is 4.8.1. The version shipped with Sage at the moment is 4.9.2. This ticket should implement install/usage of Sage's gcc if the native gcc version is less than 4.8.1. The resp. package tickets will depend on this ticket and activate the C++11 switch in their compile process.

Change History (3)

comment:1 Changed 7 years ago by Ralf Stephan

diff --git a/ b/
index 5e320f7..ed26013 100644
--- a/
+++ b/
@@ -214,6 +214,10 @@ else
                     echo >&2 "gcc-4.7.0 has a serious bug on ia64."
+            4.7.*|4.8.0)
+                # GCC 4.8.1 is needed because Sage requires C++11
+                echo >&2 "Installing GCC because you have $CXX version $GCCVERSION, and Sage needs 4.8.1 for full C++11 support."
+                need_to_install_gcc=yes;;

I don't understand. With this patch and make it will start to build gcc (toolchain) although my native gcc is 4.8.3.

comment:2 Changed 7 years ago by Jeroen Demeyer

Can you please be more concrete? Because I find this too vague: "In #18323 and in a recent thread packages were identified"

comment:3 Changed 7 years ago by Ralf Stephan

Description: modified (diff)
Note: See TracTickets for help on using tickets.