Opened 6 years ago

Closed 5 years ago

#19245 closed defect (wontfix)

segfault in sage/rings/polynomial/multi_polynomial_libsingular.so

Reported by: cnassau Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: commutative algebra Keywords: libsingular, matrix, substitution
Cc: Merged in:
Authors: Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This code crashes Sage (version 6.9.beta5, detected on the branch for #6101):

br = PolynomialRing(ZZ,"a,b,c,d,x1,x2,y1,y2")
br.inject_variables()
dct = {b:a,d:c,x1:0,x2:0,y1:0,y2:0}
L1 = matrix(br,[[x1,x2],[-x1,-x2],[y1,y2],[-y1,-y2]]).transpose().subs(dct)

Backtrace:

------------------------------------------------------------------------
/waste/cn/sage-git/local/lib/python2.7/site-packages/sage/ext/interrupt/interrupt.so(+0x4125)[0x7ff648c6a125]
/waste/cn/sage-git/local/lib/python2.7/site-packages/sage/ext/interrupt/interrupt.so(+0x4177)[0x7ff648c6a177]
/waste/cn/sage-git/local/lib/python2.7/site-packages/sage/ext/interrupt/interrupt.so(+0x6029)[0x7ff648c6c029]
/lib64/libpthread.so.0(+0xf890)[0x7ff64b9ec890]
/waste/cn/sage-git/local/lib/python2.7/site-packages/sage/rings/polynomial/multi_polynomial_libsingular.so(+0x3f1cd)[0x7ff628bd81cd]
/waste/cn/sage-git/local/lib/python2.7/site-packages/sage/matrix/matrix2.so(+0x13c2f6)[0x7ff62f9192f6]
/waste/cn/sage-git/local/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x48a9)[0x7ff64bd041f9]
/waste/cn/sage-git/local/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x80d)[0x7ff64bd05a1d]
/waste/cn/sage-git/local/lib/libpython2.7.so.1.0(PyEval_EvalCode+0x32)[0x7ff64bd05b52]
/waste/cn/sage-git/local/lib/libpython2.7.so.1.0(PyRun_FileExFlags+0x92)[0x7ff64bd30722]
/waste/cn/sage-git/local/lib/libpython2.7.so.1.0(PyRun_SimpleFileExFlags+0xd9)[0x7ff64bd31c59]
/waste/cn/sage-git/local/lib/libpython2.7.so.1.0(Py_Main+0xc4d)[0x7ff64bd479ed]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x7ff64af4fb05]
python[0x4007be]

Attachments (1)

sage_crash_PziaWp.log (17.9 KB) - added by cnassau 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by cnassau

comment:1 Changed 6 years ago by chapoton

Smaller case, still crashing in 6.9.beta7:

sage: br = PolynomialRing(ZZ,"a,x1,x2")
sage: br.inject_variables()
sage: dct = {x1:a, x2:0}
sage: matrix(br,[[x2]]).subs(dct)

comment:2 Changed 6 years ago by chapoton

  • Component changed from PLEASE CHANGE to commutative algebra

comment:3 Changed 6 years ago by chapoton

Interestingly, this seem to appear more generally when the result of substitution is zero:

sage: br = PolynomialRing(ZZ,"a,x1,x2")
sage: br.inject_variables()
sage: dct = {x1:a, x2:-1}
sage: matrix(br,[[1+x2]]).subs(dct)

BOOM!

comment:4 Changed 5 years ago by vdelecroix

  • Milestone changed from sage-6.9 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

duplicate of the already fixed #17785.

comment:5 Changed 5 years ago by jdemeyer

  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to positive_review

comment:6 Changed 5 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Determined to be invalid/duplicate/wontfix (closing as "wontfix" as a catch-all resolution).

Note: See TracTickets for help on using tickets.