Opened 5 years ago

Closed 4 years ago

#19232 closed defect (wontfix)

Metaticket: build Sage with Xcode 7

Reported by: jhpalmieri Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: fbissey, yomcat Merged in:
Authors: Reviewers: François Bissey
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jhpalmieri)

Xcode 7, released 2015-Sep-17, doesn't build all of Sage's packages correctly. Known problematic packages:

Change History (8)

comment:1 Changed 5 years ago by jhpalmieri

  • Description modified (diff)

comment:2 Changed 5 years ago by fbissey

  • Cc fbissey added

comment:3 Changed 5 years ago by jhpalmieri

Note that gsl and numpy are also dependencies for some other packages, so I haven't even tried to build those other packages yet. (These three failures were as far as I got with make -k.)

Last edited 5 years ago by jhpalmieri (previous) (diff)

comment:4 Changed 5 years ago by yomcat

  • Cc yomcat added

comment:5 Changed 4 years ago by paulmasson

Since the version of Xcode is currently 8.2, shouldn't this ticket be closed? Looks like problematic packages were addressed.

comment:6 Changed 4 years ago by fbissey

  • Milestone changed from sage-6.9 to sage-duplicate/invalid/wontfix
  • Reviewers set to François Bissey
  • Status changed from new to needs_review

comment:7 Changed 4 years ago by fbissey

  • Status changed from needs_review to positive_review

Thank you Paul for pointing out that the ticket is obsolete now.

comment:8 Changed 4 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Closing tickets in the sage-duplicate/invalid/wontfix module with positive_review (i.e. someone has confirmed they should be closed).

Note: See TracTickets for help on using tickets.