Opened 4 years ago

Last modified 4 years ago

#19198 new defect

Installation instructions in numerical_sage tutorial are obsolete

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-6.9
Component: documentation Keywords:
Cc: jhpalmieri Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

The following files

contain instructions to install a laundry list of packages.

However, those instructions don't actually work, for 2 reasons:

  1. they use install_package() which no longer works (#16760 and #16759)
  2. the packages are no longer installable anyway (#19004)

Change History (4)

comment:1 Changed 4 years ago by jdemeyer

  • Description modified (diff)

comment:2 Changed 4 years ago by jdemeyer

  • Summary changed from Installation instructions in numerical_sage tutorial is obsolete to Installation instructions in numerical_sage tutorial are obsolete

comment:3 in reply to: ↑ description Changed 4 years ago by jhpalmieri

However, those instructions don't actually work, for 2 reasons:

  1. they use install_package() which no longer works (#16760 and #16759)
  2. the packages are no longer installable anyway (#19004)
  1. Some of the packages have been archived, and automatic downloading of archived packages was broken independently (?) of #19004. With Sage 6.8, for example:
    ERROR [download|run:133]: [Errno 404] Not Found: '//mirrors.xmission.com/sage//spkg/archive/list'
    sed: /Users/palmieri/.sage//archive.list: No such file or directory
    Error: could not find a package matching python-2.5.1-framework on http://mirrors.xmission.com/sage//spkg
    
  2. On my OS X machine, python-2.5.1-framework.spkg does not install.

comment:4 Changed 4 years ago by jdemeyer

For the instructions in mpi4py.rst, I can make it work using #19158 (for openmpi) and #19187 (for mpi4py).

Note: See TracTickets for help on using tickets.