Opened 4 years ago

Closed 4 years ago

#19189 closed defect (fixed)

update prerequisites

Reported by: vbraun Owned by:
Priority: major Milestone: sage-6.9
Component: documentation Keywords:
Cc: jdemeyer Merged in:
Authors: Volker Braun Reviewers: Karl-Dieter Crisman, Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: 9ac25fa (Commits) Commit: 9ac25fac358883c0ead1422508a77d7a153474d0
Dependencies: Stopgaps:

Description (last modified by vbraun)

  • Python is required
  • Notes about redhat-derived distros

Change History (10)

comment:1 Changed 4 years ago by vbraun

  • Branch set to u/vbraun/update_prerequisites

comment:2 Changed 4 years ago by vbraun

  • Authors set to Volker Braun
  • Commit set to 9ac25fac358883c0ead1422508a77d7a153474d0
  • Component changed from PLEASE CHANGE to documentation
  • Description modified (diff)
  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to defect

New commits:

9ac25faadd python prerequisite and redhat notes

comment:3 Changed 4 years ago by kcrisman

I can definitely attest to the Python prereq!

Do Debian and Redhat not require you to install Python, e.g. is it already on the system by default? If so this looks good, except I can't attest to the redhat perl necessity so someone should.

comment:4 follow-up: Changed 4 years ago by vbraun

Every modern distro installs Python by default; E.g. a number of the system administration tools on Redhat/Fedora/Centos are written in Python. OSX includes it by default, too. The perl-ExtUtils-MakeMaker thing is true.

comment:5 in reply to: ↑ 4 Changed 4 years ago by kcrisman

Every modern distro installs Python by default; E.g. a number of the system administration tools on Redhat/Fedora/Centos are written in Python. OSX includes it by default, too.

Always has, I guess, but not all OSX has a recent enough Python for this prereq.

The perl-ExtUtils-MakeMaker thing is true.

I believe it! I just can't review it, if that makes sense? I'll leave that to someone with access to redhat.

comment:6 Changed 4 years ago by vbraun

I guess the documentation won't be updated, then

comment:7 Changed 4 years ago by kcrisman

  • Cc jdemeyer added

You think no one else might have access? I just feel a little uncomfortable giving an okay since I don't have any Linux access at all. I know that might seem picky. Jeroen?

comment:8 Changed 4 years ago by jdemeyer

  • Reviewers set to Karl-Dieter Crisman, Jeroen Demeyer
  • Status changed from needs_review to positive_review

I'm not a Debian or Redhat user either (I use Gentoo).

However, I'm willing to give Volker the benefit of the doubt that those commands do what they need to do. The patch adds "Python 2.6" as general dependency, which is a good thing. Finally, as Volker likes to remind us, "perfect is the enemy of the good".

comment:9 Changed 4 years ago by kcrisman

True dat. But at least you use Linux ;-)

comment:10 Changed 4 years ago by vbraun

  • Branch changed from u/vbraun/update_prerequisites to 9ac25fac358883c0ead1422508a77d7a153474d0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.