Opened 14 years ago

Closed 11 years ago

#191 closed enhancement (duplicate)

factorization table / database

Reported by: was Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: factorization Keywords:
Cc: mvngu Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by was)

It would be very nice if SAGE had a large table/database of integers of special forms whose factorizations are known, since a huge amount of work has already been done on this. The SAGE factor command could consult such a table, before applying other more general techniques.

For example, on the number theory list:

Look in the file
 
http://homes.cerias.purdue.edu/~ssw/bell/r1
 
for the factorizations of p^p - 1 for most p < 180.
 
(If you change "r1" to "r2", you get the factors of p^p + 1.)
 
For the meaning of the "L" and "M" notation, see the papers at
 
http://homes.cerias.purdue.edu/~ssw/bell/index.html

So a person really wanted to factor some numbers p^p -1, but couldn't with PARI. If SAGE had tables of the factorizations of those numbers, it could have done it via a lookup, and the verbose message could have given the above reference. Something similar would be good for a huge range of classes of prime numbers. This would be an excellent student project.

I believe the Cunningham project has large tables of factored integers of a special form. This might be a useful resource for those wanting to undertake this project.

Change History (12)

comment:1 Changed 14 years ago by was

  • Priority changed from major to minor

comment:2 Changed 14 years ago by was

  • Description modified (diff)

comment:3 Changed 14 years ago by was

  • Description modified (diff)
  • Summary changed from prime table / database to factorization table / database

comment:4 Changed 14 years ago by was

  • Description modified (diff)

comment:5 Changed 14 years ago by mabshoff

  • Milestone set to sage-feature

comment:6 Changed 12 years ago by mvngu

  • Cc mvngu added

CC'ing myself.

comment:7 Changed 12 years ago by davidloeffler

  • Component changed from number theory to factorization
  • Owner changed from was to tbd

comment:8 Changed 11 years ago by jdemeyer

  • Report Upstream set to N/A
  • Resolution set to duplicate
  • Status changed from new to closed

See #7239

comment:9 Changed 11 years ago by davidloeffler

  • Resolution duplicate deleted
  • Status changed from closed to new

Please do not close tickets yourself. Only release managers have the authority to do this.

comment:10 Changed 11 years ago by davidloeffler

  • Status changed from new to needs_review

comment:11 Changed 11 years ago by davidloeffler

  • Status changed from needs_review to positive_review

What I usually do in this situation is to set the ticket to "needs review" with a message saying I think it ought to be closed. Then if someone else agrees, we can set it to "positive review", and then it'll show up in the list of tickets to be merged in the next release. Then the release manager will close it. In this case, I've put it at "positive review", since I agree with your claim that it should be fixed.

BTW, I'm not sure "duplicate" is fair; this ticket has been open for years, so #7239 was a duplicate of this one rather than the other way round. Perhaps "fixed" is the most appropriate resolution. But that is for the release manager to decide.

comment:12 Changed 11 years ago by mpatel

  • Milestone changed from sage-feature to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from positive_review to closed

I'm resolving this as a "duplicate," simply because the only relevant milestone is "sage-duplicate/invalid/wontfix."

Note: See TracTickets for help on using tickets.