Opened 4 years ago

Closed 4 years ago

#19066 closed defect (fixed)

Constructing an empty polyhedron raises AssertionError

Reported by: yzh Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: geometry Keywords: polyhedron
Cc: mkoeppe, vbraun Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Got AssertionError when constructing Polyhedron from an H-representation that has unusual base_ring and is infeasible,

sage: Polyhedron(ieqs=[(-sqrt(2),1,1),(0,-1,-1)])
AssertionError
sage: Polyhedron(ieqs=[(-sqrt(2),1,1),(0,-1,-1)], base_ring=AA)
AssertionError

whereas the following works well.

sage: Polyhedron(ieqs=[(-1.414,1,1),(0,-1,-1)])
The empty polyhedron in RDF^2
sage: Polyhedron(ieqs=[(sqrt(2),1,1),(0,-1,-1)])

Change History (4)

comment:1 Changed 4 years ago by mkoeppe

  • Keywords polyhedron added
  • Status changed from new to needs_info

I can't reproduce this with 6.9.beta2

comment:2 Changed 4 years ago by mkoeppe

  • Milestone changed from sage-6.9 to sage-duplicate/invalid/wontfix

comment:3 Changed 4 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_info to positive_review

comment:4 Changed 4 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.