Opened 5 years ago

Closed 5 years ago

#19064 closed defect (fixed)

Equality shouldn't also be unequal

Reported by: kcrisman Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers: Ralf Stephan
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

bool((1/8*sqrt(2)*(sqrt(2)*(sqrt(2) - 2) + 4*sqrt(2)) + 1/4*sqrt(2)*(sqrt(2) - 2) + 3/4*sqrt(2) - 1/2) < (1/8*sqrt(2)*(sqrt(2) + 2) + 1/4*sqrt(2) + 1/4))

apparently yields True, though these expressions are apparently actually equal. See this ask.sagemath question for details.

Change History (5)

comment:1 Changed 5 years ago by nbruin

Can't reproduce this on 6.9beta (I get false for < and true for ==)

comment:2 Changed 5 years ago by rws

  • Milestone changed from sage-6.9 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

That was fixed in #18896

comment:3 Changed 5 years ago by rws

  • Status changed from needs_review to positive_review

comment:4 Changed 5 years ago by kcrisman

  • Reviewers set to Ralf Stephan

Awesome, thanks. I'm sorry for not checking myself, only had time to report it before I forgot and it got lost.

comment:5 Changed 5 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.