Opened 4 years ago

Closed 2 years ago

#19050 closed defect (duplicate)

hash values for matrices

Reported by: vdelecroix Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: linear algebra Keywords:
Cc: nbruin, ncohen Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by vdelecroix)

The current hash for matrices is a complete mess

sage: M = MatrixSpace(GF(3),2,2).list()
sage: for m in M: m.set_immutable()
sage: len(M)
81
sage: len(set(map(hash,M)))
8

duplicate of #10950

Change History (3)

comment:1 Changed 2 years ago by kedlaya

Would this be resolved by #10950?

comment:2 Changed 2 years ago by vdelecroix

  • Dependencies #19016 deleted
  • Description modified (diff)
  • Milestone changed from sage-6.9 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:3 Changed 2 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.