Opened 6 years ago

Closed 6 years ago

#19039 closed defect (duplicate)

Underlinked combinat/partitions.pyx with NTL

Reported by: tscrim Owned by: tscrim
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords: linking, NTL
Cc: jpflori Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: public/link_ntl_partitions-19039 (Commits, GitHub, GitLab) Commit: f6a03e8e3426d0cb482fa44f25d1417579d1d28f
Dependencies: Stopgaps:

Status badges

Description

Cygwin requires more explicit linking for src/combinat/partitions.pyx in order to build.

Change History (5)

comment:1 Changed 6 years ago by tscrim

If my cygwin build finishes (and Sage starts), I will push a branch.

comment:2 Changed 6 years ago by tscrim

  • Authors set to Travis Scrimshaw
  • Branch set to public/link_ntl_partitions-19039
  • Commit set to f6a03e8e3426d0cb482fa44f25d1417579d1d28f
  • Status changed from new to needs_review

New commits:

f6a03e8Added NTL linking for partitions.pyx.

comment:3 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to needs_work

Please add the libraries to the source file, not module_list.py.

comment:4 Changed 6 years ago by jdemeyer

  • Authors Travis Scrimshaw deleted
  • Milestone changed from sage-6.9 to sage-duplicate/invalid/wontfix
  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_work to positive_review

Duplicate of #19051.

comment:5 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.