Opened 6 years ago

Closed 4 years ago

#18971 closed defect (duplicate)

make first call of gap3.execute work properly

Reported by: saliola Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: interfaces: optional Keywords: gap3
Cc: stumpc5, nthiery Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

As pointed out at #8906:

Do you know why the first call of gap3 doesn't appear to work properly?

┌────────────────────────────────────────────────────────────────────┐
│ SageMath Version 6.8.rc1, Release Date: 2015-07-22                 │
│ Type "notebook()" for the browser-based notebook interface.        │
│ Type "help()" for help.                                            │
└────────────────────────────────────────────────────────────────────┘
┏━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┓
┃ Warning: this is a prerelease version, and it may be unstable.     ┃
┗━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┛
sage: gap3
Gap3
sage: gap3.execute("1+1")
''
sage: gap3.execute("1+1")
'2'
sage: 

Note that running gap3("1 + 1") works correctly.

[Of course, one needs gap3 installed to see this error. Either install it using the SPKG at #8906, or install it on your system and make sure that gap3 is in your $PATH.]

Change History (7)

comment:1 Changed 5 years ago by stumpc5

There are also the following, maybe related, issues

┌────────────────────────────────────────────────────────────────────┐
│ SageMath Version 7.1.beta6, Release Date: 2016-03-03               │
│ Type "notebook()" for the browser-based notebook interface.        │
│ Type "help()" for help.                                            │
└────────────────────────────────────────────────────────────────────┘
┏━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┓
┃ Warning: this is a prerelease version, and it may be unstable.     ┃
┗━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┛
sage:  
sage: gap3
Gap3
sage: gap3.execute("1+1")
''
sage: gap3.execute("1+1")
'2'
sage: 
sage: gap3.execute("1+1")
'2'
sage: gap3
Gap3
sage: gap3.eval('VERSION')[1:-1]
''
sage: gap3.eval('VERSION')[1:-1]
'lib: jm 12Mar2016, src: jm 28Feb2015, sys: usg gcc 64'
sage: gap3.execute("1+1")
'"lib: jm 12Mar2016, src: jm 28Feb2015, sys: usg gcc 64"'
sage: gap3.execute("1+1")
'2'

comment:2 Changed 5 years ago by stumpc5

See also #20107 for a new attempt to make GAP3 an optional package.

comment:3 Changed 4 years ago by stumpc5

  • Cc nthiery added
  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to defect

duplicate of #23142

comment:4 Changed 4 years ago by nthiery

For the record: I just checked that with #23142, the given examples work smoothly. Hence positive review!

comment:5 Changed 4 years ago by nthiery

  • Status changed from needs_review to positive_review

comment:6 Changed 4 years ago by nthiery

(i.e.: can be closed as duplicate)

comment:7 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-6.9 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.