Opened 7 years ago

Last modified 5 years ago

#18920 closed defect

upgrade Maxima and ECL to 5.36.0.1 and 15.3.7, respectively — at Version 6

Reported by: dimpase Owned by:
Priority: major Milestone: sage-7.6
Component: symbolics Keywords:
Cc: rws, jpflori, kcrisman, nbruin, jdemeyer, vbraun, charpent Merged in:
Authors: Reviewers:
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: u/dimpase/eclupdate (Commits, GitHub, GitLab) Commit: 045d21eeb356b04102696d1aa51776b1330c635a
Dependencies: Stopgaps:

Status badges

Description (last modified by dimpase)

this would fix some bugs, e.g. as reported here.

  • get Maxima here (then git checkout 5.36.0.1); the tarball; note that sf.net with tarballs is down...
  • ECL git here and apparently the tarball can be obtained there, too. But it is not useful without renaming, etc.

ecl tarball to use is here

Change History (6)

comment:1 Changed 7 years ago by dimpase

  • Cc rws added
  • Description modified (diff)

comment:2 Changed 7 years ago by dimpase

  • Description modified (diff)

comment:3 Changed 7 years ago by dimpase

  • Description modified (diff)

comment:4 Changed 7 years ago by fbissey

For info, I have been using ecl 15.3.7 for a while in sage-on-gentoo. That part is a straight upgrade as far as I can see. I do not remember having tried a newer maxima but it usually breaks a lest a couple of doctest.

comment:5 Changed 7 years ago by fbissey

I tried maxima 5.36.0 and reverted (that was with ecl 15.3.7) , not tried 5.36.1 (5.36.0.1 whatever the version number is actually).

     Wed Apr 29 11:14:49 2015 >>> sci-mathematics/maxima-5.35.1-r2
       merge time: 5 minutes and 6 seconds.

     Fri May  1 10:33:58 2015 >>> sci-mathematics/maxima-5.36.0
       merge time: 4 minutes and 52 seconds.

     Fri May  1 10:42:03 2015 >>> sci-mathematics/maxima-5.35.1-r2
       merge time: 5 minutes and 8 seconds.

comment:6 Changed 7 years ago by dimpase

  • Branch set to u/dimpase/eclupdate
  • Cc jpflori added
  • Commit set to 045d21eeb356b04102696d1aa51776b1330c635a
  • Description modified (diff)

The branch is currently not working; to build the new ecl pkg, one has to move patches/implib.patch out of the way; I tried porting the latter patch to the new ecl, but it produces a makefile error that I don't understand; anyway, it is cygwin-specific.

I cc its author now. J.-P., any ideas?

Note: See TracTickets for help on using tickets.