Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#18879 closed defect (duplicate)

Doctests of database_gap happen to depend on gap_packages

Reported by: charpent Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: vbraun Merged in:
Authors: Dima Pasechnik Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Starting with 6.8beta8, these two doctests :

sage -t --long --warn-long 65.9 src/sage/groups/perm_gps/permgroup_named.py  # 2 doctests failed
sage -t --long --warn-long 65.9 src/sage/tests/gap_packages.py  # 1 doctest failed

fail with database_gap installed but succeed after installation of gap_packages.

Change History (3)

comment:1 Changed 6 years ago by dimpase

  • Cc vbraun added
  • Status changed from new to needs_review

This is fixed in https://github.com/sagemath/sage/pull/43

I wonder if there is a way to unify this with the branch to be reported on the ticket (well, hopefully this is not necessary).

comment:2 Changed 6 years ago by jdemeyer

Has anybody checked that the problem is really that those doctests themselves are the problem? i.e. do make distclean, install database_gap and check the doctests...

comment:3 Changed 6 years ago by vbraun

  • Authors set to Dima Pasechnik
  • Milestone changed from sage-6.8 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers set to Volker Braun
  • Status changed from needs_review to closed

Duplicate of #18880

Last edited 6 years ago by vbraun (previous) (diff)
Note: See TracTickets for help on using tickets.