Opened 6 years ago

Closed 6 years ago

#18730 closed defect (worksforme)

SIGINT ignored by mirror search

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

No Ctrl-C had success during this:

Searching fastest mirror
  705ms: http://echidna.maths.usyd.edu.au/sage/
  554ms: http://files.sagemath.org/
  319ms: http://ftp.kaist.ac.kr/sage/
  384ms: http://ftp.leg.uct.ac.za/pub/packages/sage/
...

The later download attempts could be interrupted however.

System is Sage-6.8.beta4 on OpenSuSE 13.2 in a Konsole.

Change History (8)

comment:1 Changed 6 years ago by jdemeyer

  • Summary changed from SIGTERM ignored by mirror search to SIGINT ignored by mirror search

comment:2 follow-up: Changed 6 years ago by jdemeyer

Works for me, which Python version are you using?

comment:3 in reply to: ↑ 2 Changed 6 years ago by rws

Replying to jdemeyer:

Works for me, which Python version are you using?

2.7

comment:4 Changed 6 years ago by jdemeyer

With the Python from Sage, I get:

Searching fastest mirror
  333ms: http://echidna.maths.usyd.edu.au/sage/
  158ms: http://files.sagemath.org/
  276ms: http://ftp.kaist.ac.kr/sage/
  154ms: http://ftp.leg.uct.ac.za/pub/packages/sage/
  270ms: http://ftp.riken.jp/sagemath/
  295ms: http://ftp.tsukuba.wide.ad.jp/software/sage/
  270ms: http://ftp.yz.yamagata-u.ac.jp/pub/math/sage/
  425ms: http://jambu.spms.ntu.edu.sg/sage/
  213ms: http://linorg.usp.br/sage/
  345ms: http://mirror.aarnet.edu.au/pub/sage/
 2036ms: http://mirror.hust.edu.cn/sagemath/
   26ms: http://mirror.switch.ch/mirror/sagemath/
  206ms: http://mirror.ufs.ac.za/sagemath/
   75ms: http://mirror.yandex.ru/mirrors/sage.math.washington.edu/
   68ms: http://mirrors-ru.go-parts.com/sage/sagemath/
   26ms: http://mirrors-uk.go-parts.com/sage/sagemath/
  132ms: http://mirrors-usa.go-parts.com/sage/sagemath/
   52ms: http://mirrors.fe.up.pt/pub/sage/
   98ms: http://mirrors.mit.edu/sage/
^CTraceback (most recent call last):
  File "/usr/local/src/sage-config/src/bin/sage-download-file", line 457, in <module>
    tarball.download()
  File "/usr/local/src/sage-config/src/bin/sage-download-file", line 392, in download
    for mirror in MirrorList():
  File "/usr/local/src/sage-config/src/bin/sage-download-file", line 155, in __init__
    self._rank_mirrors()
  File "/usr/local/src/sage-config/src/bin/sage-download-file", line 205, in _rank_mirrors
    sock = socket.create_connection((mirror_hostname, port), timeout)
  File "/usr/local/src/sage-config/local/lib/python/socket.py", line 555, in create_connection
    for res in getaddrinfo(host, port, 0, SOCK_STREAM):
KeyboardInterrupt

comment:5 Changed 6 years ago by jdemeyer

What actually happens when you press CTRL-C? It's not really clear from the description.

comment:6 Changed 6 years ago by rws

  • Milestone changed from sage-6.8 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Cannot reproduce any more, sorry. Maybe there is an issue with my keyboard.

comment:7 Changed 6 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

comment:8 Changed 6 years ago by vbraun

  • Resolution set to worksforme
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.