Opened 6 years ago

Closed 6 years ago

#18692 closed defect (duplicate)

Fix downloading mirrorlist using python 3

Reported by: aapitzsch Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords: python3
Cc: Merged in:
Authors: André Apitzsch Reviewers:
Report Upstream: N/A Work issues:
Branch: u/aapitzsch/ticket/18692 Commit: 98230971972207c910c1177be28bdbcb16b71312
Dependencies: Stopgaps:

Status badges

Description

Downloading the Sage mirror list
Traceback (most recent call last):
  File "./src/bin/sage-download-file", line 457, in <module>
    tarball.download()
  File "./src/bin/sage-download-file", line 392, in download
    for mirror in MirrorList():
  File "./src/bin/sage-download-file", line 154, in __init__
    self.mirrors = self._load(mirror_list)
  File "./src/bin/sage-download-file", line 169, in _load
    return ast.literal_eval(mirror_list)
  File "/opt/sage-py3/local/lib/python3.4/ast.py", line 84, in literal_eval
    return _convert(node_or_string)
  File "/opt/sage-py3/local/lib/python3.4/ast.py", line 83, in _convert
    raise ValueError('malformed node or string: ' + repr(node))
ValueError: malformed node or string: b'#...

Change History (3)

comment:1 Changed 6 years ago by aapitzsch

  • Branch set to u/aapitzsch/ticket/18692
  • Commit set to 98230971972207c910c1177be28bdbcb16b71312
  • Status changed from new to needs_review

comment:2 Changed 6 years ago by aapitzsch

  • Milestone changed from sage-6.8 to sage-duplicate/invalid/wontfix
  • Status changed from needs_review to positive_review

Duplicate of #18719.

comment:3 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.