Opened 15 years ago

Closed 15 years ago

#1864 closed defect (fixed)

[with patch; positive review] simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)

Reported by: William Stein Owned by: Kelly Boothby
Priority: major Milestone: sage-3.0.2
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Try this in the notebook

# This is a question?

and hit shift enter. You get introspection on the word "question".

Attachments (1)

sage-1864.patch (1.2 KB) - added by William Stein 15 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 15 years ago by Kelly Boothby

Milestone: sage-2.11sage-2.10.4

I can't reproduce this in Firefox or Opera -- has it been fixed?

comment:2 Changed 15 years ago by William Stein

This is easy to reproduce in firefox and has not been fixed. See this screenshot:

http://sage.math.washington.edu/home/was/tmp/screenshot-comment.png

Changed 15 years ago by William Stein

Attachment: sage-1864.patch added

comment:3 Changed 15 years ago by William Stein

Summary: simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)[with patch; needs review] simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)

comment:4 Changed 15 years ago by Kelly Boothby

Summary: [with patch; needs review] simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)[with patch; positive review pending commentary] simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)

This breaks previously supported functionality (that I won't miss). It used to be, one could type

foo?

and press shift-enter to introspect. I give this a positive review *if* that was an intended change.

comment:5 Changed 15 years ago by William Stein

Summary: [with patch; positive review pending commentary] simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)[with patch; needs review] simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)

The referee claims that say

log?[shift-enter]

doesn't work.

However it *does* work fine with this patch. The referee needs to try again.

comment:6 Changed 15 years ago by Kelly Boothby

Summary: [with patch; needs review] simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)[with patch; positive review] simple notebook bug -- typing ? in a comment yields introspection but shouldn't (easy to fix in worksheet.py, probably)

Weird. Works now.

comment:7 Changed 15 years ago by Michael Abshoff

Resolution: fixed
Status: newclosed

Merged in Sage 3.0.2.alpha1

Note: See TracTickets for help on using tickets.