Opened 6 years ago

Closed 6 months ago

Last modified 6 months ago

#18598 closed defect (worksforme)

reduce method of polynomial ideals gives incorrect results

Reported by: lftabera Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords: days94
Cc: dimpase Merged in:
Authors: Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by slelievre)

Define the following polynomial ring, polynomial, and ideal:

sage: term_order = TermOrder('degrevlex', 2) + TermOrder('degrevlex', 2)
sage: K = PolynomialRing(QQ, 'x,y,a0,a1', order=term_order)
sage: x, y, a0, a1 = K.gens()
sage: f = x**3 + x**2*y
sage: m = Ideal(x**4, x**2*y, y**2)

Before #27508, we get an incorrect reduction:

sage: m.reduce(f) == f.reduce(m.groebner_basis())
False
sage: m.reduce(f)
x^3 + x^2*y
sage: f.reduce(m.groebner_basis())
x^3

Singular computes correctly the reduction as x^3.

The problem is we call singular via libsingular without asking for tail reduction.

This was fixed in #27508, after which we get correct results:

sage: m.reduce(f) == f.reduce(m.groebner_basis())
True
sage: m.reduce(f)
x^3
sage: f.reduce(m.groebner_basis())
x^3

Change History (7)

comment:1 Changed 3 years ago by lftabera

  • Keywords days94 added
  • Milestone changed from sage-6.8 to sage-8.3

comment:2 Changed 3 years ago by lftabera

I am not able to debug this. For me, it seems that this is an error in libsingular and, probably, a duplicate of #12529

comment:3 Changed 3 years ago by vdelecroix

  • Milestone changed from sage-8.3 to sage-8.4

update milestone 8.3 -> 8.4

comment:4 Changed 8 months ago by gh-mwageringel

  • Cc dimpase added
  • Milestone changed from sage-8.4 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This works correctly in 9.2.beta10, possibly since #27508.

comment:5 Changed 8 months ago by dimpase

  • Reviewers set to Dima Pasechnik
  • Status changed from needs_review to positive_review

indeed

comment:6 Changed 6 months ago by slelievre

  • Resolution set to worksforme
  • Status changed from positive_review to closed

comment:7 Changed 6 months ago by slelievre

  • Description modified (diff)
Note: See TracTickets for help on using tickets.