Changes between Version 1 and Version 2 of Ticket #18555, comment 3


Ignore:
Timestamp:
06/28/16 11:18:25 (5 years ago)
Author:
andrew.mathas
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #18555, comment 3

    v1 v2  
    1 As I am cleaning this up a related question comes to mind: the name `GlobalOptions` is a slightly unfortunate because instances of this class are really just options for an associated family of objects. I can sort of forgive myself for using this name for the class, but in all of the instances of this class the associated "parent" classes have a `global_options` method that points back to its options class. This method is now being enshrined more firmly inside the code because it is exploited to allow pickling. I would be happier if these methods were simply called `options`, rather than `global_options`, even though this change would necessitate deprecating the existing `global_options` methods.
     1As I am cleaning this up a related question comes to mind: the name `GlobalOptions` is slightly unfortunate because instances of this class are really just options for an associated family of objects. I can sort of forgive myself for using this name for the class, but in all of the instances of this class the associated "parent" classes have a `global_options` method that points back to its options class. This method is now being enshrined more firmly inside the code because it is exploited to allow pickling. I would be happier if these methods were simply called `options`, rather than `global_options`, even though this change would necessitate deprecating the existing `global_options` methods.
    22
    33Thoughts?