Opened 4 years ago

Closed 2 years ago

#18521 closed defect (wontfix)

Python3 package may be broken on OS X

Reported by: jhpalmieri Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: ohanar Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

After installing the Python 3 package from #17607 on OS X 10.10.3, Xcode 6.3.1, I see

/Users/palmieri/Desktop/Sage_stuff/git/sage/src/bin/sage-env: line 411: 33785 Abort trap: 6           "$SAGE_ROOT/local/bin/python" -c 'import pkg_resources; pkg_resources.get_distribution("matplotlib").version' 2> /dev/null
Fatal Python error: Py_Initialize: unable to load the file system codec
  File "/Users/palmieri/Desktop/Sage_stuff/git/sage/local/lib/python/encodings/__init__.py", line 123
    raise CodecRegistryError,\
                            ^
SyntaxError: invalid syntax
/usr/local/bin/sage: line 134: 33763 Abort trap: 6           "$SAGE_ROOT/src/bin/sage" "$@"

The same happened on a machine with just the Xcode command-line tools installed.

Change History (7)

comment:1 Changed 4 years ago by jhpalmieri

To be completely clear, I got this failure using the branch at #18517 because git trac checkout 17607 failed earlier today. But I don't think #18517 has anything to do with the error here.

comment:2 Changed 4 years ago by ohanar

Hmm, this seems harder to fix than I first thought. Sage has been setup to really only have one version of Sage installed at a time (there is a heavy reliance on have PYTHONHOME set, which breaks having multiple versions installed).

comment:3 Changed 3 years ago by chapoton

  • Milestone changed from sage-6.8 to sage-7.3

comment:4 Changed 3 years ago by chapoton

see also #20215

comment:5 Changed 3 years ago by jhpalmieri

  • Milestone changed from sage-7.3 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

#22756 is a duplicate of this one. Since there is a branch at #22756, let's close this.

comment:6 Changed 3 years ago by jhpalmieri

  • Status changed from needs_review to positive_review

comment:7 Changed 2 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Closing tickets in the sage-duplicate/invalid/wontfix module with positive_review (i.e. someone has confirmed they should be closed).

Note: See TracTickets for help on using tickets.