Opened 4 years ago

Closed 4 years ago

#18414 closed defect (fixed)

Fix download of configure tarball in bootstrap

Reported by: darij Owned by:
Priority: blocker Milestone: sage-6.7
Component: build Keywords: dependencies, automake, aclocal, build, bdist
Cc: vbraun, jdemeyer, ncohen Merged in:
Authors: Volker Braun Reviewers: Leif Leonhardy
Report Upstream: N/A Work issues:
Branch: 7e1b78a (Commits) Commit: 7e1b78a13ca8953699491d02d77d4fb9386db50c
Dependencies: Stopgaps:

Description (last modified by leif)

Trying to make-build 6.7.beta5 without automake breaks, reporting that aclocal is missing.

./sage -bdist also fails.

Change History (12)

comment:1 Changed 4 years ago by darij

  • Description modified (diff)

comment:2 Changed 4 years ago by jdemeyer

  • Component changed from distribution to packages: standard
  • Description modified (diff)
  • Priority changed from major to blocker
  • Summary changed from Undeclared dependency on automake to Fix building Sage without automake

Obviously, we need the log...

comment:3 Changed 4 years ago by ncohen

  • Cc ncohen added

comment:4 Changed 4 years ago by vbraun

Can reproduce

./bootstrap -d
rm -rf config configure build/Makefile-auto.in
./bootstrap: line 29: aclocal: command not found
Bootstrap failed, downloading required files instead.
Traceback (most recent call last):
  File "/Users/buildslave-sage/slave/sage_git/build/src/bin/sage-download-file", line 417, in <module>
    tarball = Tarball(url)
  File "/Users/buildslave-sage/slave/sage_git/build/src/bin/sage-download-file", line 265, in __init__
    self._init_checksum()
  File "/Users/buildslave-sage/slave/sage_git/build/src/bin/sage-download-file", line 301, in _init_checksum
    with open(checksums_ini, 'rt') as f:
IOError: [Errno 2] No such file or directory: '/configure/configure/checksums.ini'
Error: downloading configure-91.tar.gz failed
make: *** [configure] Error 1
make: Target `start' not remade because of errors.
program finished with exit code 2
elapsedTime=0.683506

comment:5 Changed 4 years ago by vbraun

  • Branch set to u/vbraun/fix_building_sage_without_automake

comment:6 Changed 4 years ago by vbraun

  • Authors set to Volker Braun
  • Commit set to 7e1b78a13ca8953699491d02d77d4fb9386db50c
  • Status changed from new to needs_review

New commits:

7e1b78afix download of the confball

comment:7 Changed 4 years ago by leif

FWIW, sage-download-file still needs to get fixed w.r.t. filenames including a path, but probably on another ticket.

Actually, the whole interface changed, but the error here was caused by SAGE_UPSTREAM no longer being set (removed from sage-env by #15642), hence sage-download-file didn't get a URL.

comment:8 follow-up: Changed 4 years ago by vbraun

Whats the problem with filenames containing a path? Either tarball-name of full url works. It doesn't make sense to have directory components in tarball names.

comment:9 in reply to: ↑ 8 Changed 4 years ago by leif

Replying to vbraun:

Whats the problem with filenames containing a path? Either tarball-name of full url works. It doesn't make sense to have directory components in tarball names.

Exactly. But sage-download-file doesn't catch that error.

comment:10 Changed 4 years ago by vbraun

Its not really meant for interactive use, raising an exception is the correct behavior. If you mean that you want a ValueError instead of IOError then feel free to open a ticket.

comment:11 Changed 4 years ago by leif

  • Component changed from packages: standard to build
  • Description modified (diff)
  • Keywords bdist added
  • Reviewers set to Leif Leonhardy
  • Status changed from needs_review to positive_review
  • Summary changed from Fix building Sage without automake to Fix download of configure tarball in bootstrap

comment:12 Changed 4 years ago by vbraun

  • Branch changed from u/vbraun/fix_building_sage_without_automake to 7e1b78a13ca8953699491d02d77d4fb9386db50c
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.