Opened 15 years ago

Closed 15 years ago

#1839 closed enhancement (fixed)

[with script; positive] sage-crap: incorporate this script into sage and start using it before each release.

Reported by: was Owned by: mabshoff
Priority: major Milestone: sage-3.0.4
Component: packages: standard Keywords: editor_wstein
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description


Attachments (2)

crap.patch (23.6 KB) - added by boothby 15 years ago.
scripts-1839.patch (1.5 KB) - added by was 15 years ago.
part 2 of the patch

Download all attachments as: .zip

Change History (17)

comment:1 Changed 15 years ago by mabshoff

Component: commutative algebrapackages
Owner: changed from malb to mabshoff

comment:2 Changed 15 years ago by rlm

Milestone: sage-2.11sage-2.10.4

comment:3 Changed 15 years ago by was

I BSD license this file

* Copyright (c) 2008, William Stein (with permission)
* All rights reserved.
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions are met:
*     * Redistributions of source code must retain the above copyright
*       notice, this list of conditions and the following disclaimer.
*     * Redistributions in binary form must reproduce the above copyright
*       notice, this list of conditions and the following disclaimer in the
*       documentation and/or other materials provided with the distribution.
*     * Neither the name of the Sage Project nor the
*       names of its contributors may be used to endorse or promote products
*       derived from this software without specific prior written permission.
*
* THIS SOFTWARE IS PROVIDED BY WILLIAM STEIN ``AS IS'' AND ANY
* EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
* WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
* DISCLAIMED. IN NO EVENT SHALL William Stein BE LIABLE FOR ANY
* DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
* (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
* ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
* (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
* SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Changed 15 years ago by boothby

Attachment: crap.patch added

comment:5 Changed 15 years ago by boothby

Summary: [with script; needs review and integration] sage-crap: incorporate this script into sage and start using it before each release.[with script; needs review] sage-crap: incorporate this script into sage and start using it before each release.

The attached patch integrates sage-crap, and works on my machines. (debian xeon / ubuntu 32bit)

comment:6 Changed 15 years ago by mabshoff

A couple remarks:

  • is this script still destructive? In that care it should be mentioned in the help
  • the script does deal with spkgs and not tars per se - maybe the help in sage-sage should be changed?

Other than we might want to add a -crapall option since that is likely the default way one would deploy such a script, i.e. before a release. Maybe even adding a crap score might be a good thing :)

Cheers,

Michael

comment:7 Changed 15 years ago by craigcitro

Keywords: editor_wstein added

comment:8 Changed 15 years ago by was

Summary: [with script; needs review] sage-crap: incorporate this script into sage and start using it before each release.[with script; needs work] sage-crap: incorporate this script into sage and start using it before each release.

The referee report is above by malb. William Stein will do the work to fix this patch.

comment:9 Changed 15 years ago by was

Example of using this with runlevel=1 on sage-3.0.3.alpha2 -- where we see there is some crap!:

was@sage:~/build/sage-3.0.3.alpha2$ ./sage -crap sage-3.0.3.alpha2.tar 
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2.tar
runlevel=  1
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/src-gmp/.DS_Store: JVT NAL sequence
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/src/.DS_Store: JVT NAL sequence
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/lib-src/.DS_Store.1: JVT NAL sequence
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/lib-src/.DS_Store: empty
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/lib-src-gmp/.DS_Store.1: JVT NAL sequence
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/lib-src-gmp/.DS_Store: empty
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/doc/.DS_Store.1: JVT NAL sequence
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/doc/cddlibman.aux: LaTeX auxiliary file
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/doc/cddlibman.dvi: TeX DVI
/home/was/.sage/temp/sage/32206/dir_0/sage-3.0.3.alpha2/spkg/standard/cddlib-094b.p2/src/doc/cddlibman.toc: UNKNOWN
cddlibman.toc: LaTeX  table of contents

Changed 15 years ago by was

Attachment: scripts-1839.patch added

part 2 of the patch

comment:10 Changed 15 years ago by was

Summary: [with script; needs work] sage-crap: incorporate this script into sage and start using it before each release.[with script; needs review] sage-crap: incorporate this script into sage and start using it before each release.

comment:11 Changed 15 years ago by was

I requested boothby to review this.

comment:12 Changed 15 years ago by craigcitro

Summary: [with script; needs review] sage-crap: incorporate this script into sage and start using it before each release.[with script; under review by boothby before 6/27] sage-crap: incorporate this script into sage and start using it before each release.

comment:13 Changed 15 years ago by was

Milestone: sage-3.0.6sage-3.0.4
Summary: [with script; under review by boothby before 6/27] sage-crap: incorporate this script into sage and start using it before each release.[with script; positive] sage-crap: incorporate this script into sage and start using it before each release.

I consider my having read over it as a review and my little integration patch as part of that.

comment:14 Changed 15 years ago by mabshoff

Merged in Sage 3.0.4.rc0. I also give this ticket a positive review and all issues that crop up will be dealt with on follow up tickets.

Cheers,

Michael

comment:15 Changed 15 years ago by mabshoff

Resolution: fixed
Status: newclosed

Merged in Sage 3.0.4.rc0

Note: See TracTickets for help on using tickets.