Opened 4 years ago

Closed 3 years ago

#18345 closed defect (fixed)

fix bug in fricas/axiom output

Reported by: github/billpage Owned by:
Priority: major Milestone: sage-6.7
Component: interfaces: optional Keywords:
Cc: Merged in:
Authors: Bill Page Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: 384afb6 (Commits) Commit: 384afb6cf65ed07bf4bb0e7275e67a66cd3efcff
Dependencies: Stopgaps:

Description

Do not chop first character of each line.

https://github.com/sagemath/sage/pull/39

Change History (12)

comment:1 Changed 4 years ago by github

  • Branch set to u/github/ticket/18345
  • Status changed from new to needs_review

comment:2 Changed 4 years ago by git

  • Commit set to 237df92ef4e6b5117654f3a3ff71b4aa10b0aa36

Branch pushed to git repo; I updated commit sha1. New commits:

237df92fix bug in fricas/axiom output

comment:3 Changed 4 years ago by github

github/billpage wrote:

Well, I have tried this pull request thing. Not sure I understand it yet.

comment:4 Changed 4 years ago by github

github/dimpase wrote:

Well, I see it, but I suppose I am not blessed with direct commit rights to merge it. Let me that the issue is discussed here: https://groups.google.com/d/msg/sage-cloud/_Miielrv8Yw/XjWexn8d7nsJ and this fix is also needed for Sage nb display (and for terminal...)

comment:5 Changed 4 years ago by git

  • Commit changed from 237df92ef4e6b5117654f3a3ff71b4aa10b0aa36 to c2848b8168bcd6cb6efd2407109ee958368ddd4a

Branch pushed to git repo; I updated commit sha1. New commits:

c2848b8Doctest for 'fix bug in fricas/axiom output'

comment:6 Changed 4 years ago by kcrisman

  • Component changed from PLEASE CHANGE to interfaces
  • Type changed from PLEASE CHANGE to defect

comment:7 Changed 4 years ago by git

  • Commit changed from c2848b8168bcd6cb6efd2407109ee958368ddd4a to 434cc329d69833d01bbb1d203922a7ff116ed334

Branch pushed to git repo; I updated commit sha1. New commits:

5e3722efix bug in fricas/axiom output
720b7cdDoctest for 'fix bug in fricas/axiom output'
5f14dbbDont need synchronize
434cc32Merge branch 'master' of https://github.com/billpage/sage

comment:8 Changed 4 years ago by git

  • Commit changed from 434cc329d69833d01bbb1d203922a7ff116ed334 to 384afb6cf65ed07bf4bb0e7275e67a66cd3efcff

Branch pushed to git repo; I updated commit sha1. New commits:

384afb6Handle more variables

comment:9 Changed 4 years ago by jdemeyer

  • Component changed from interfaces to interfaces: optional

comment:10 Changed 3 years ago by vdelecroix

What does the following fixes

+            vars=sage.symbolic.ring.var(str(self.variables())[1:-1])
+            if isinstance(vars,tuple):
+                return sage.misc.sage_eval.sage_eval(self.unparsed_input_form(), locals={str(x):x for x in vars})
+            else:
+                return sage.misc.sage_eval.sage_eval(self.unparsed_input_form(), locals={str(vars):vars})

There should be at least one doctest for that.

comment:11 Changed 3 years ago by vbraun

  • Authors set to Bill Page
  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:12 Changed 3 years ago by vbraun

  • Branch changed from u/github/ticket/18345 to 384afb6cf65ed07bf4bb0e7275e67a66cd3efcff
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.