Opened 4 years ago

Closed 4 years ago

#18296 closed defect (fixed)

Emphasize that Graph.subgraph_search ignores edge labels

Reported by: ncohen Owned by:
Priority: major Milestone: sage-6.7
Component: graph theory Keywords:
Cc: tmonteil, vdelecroix, dcoudert Merged in:
Authors: Nathann Cohen Reviewers: David Coudert
Report Upstream: N/A Work issues:
Branch: 87d0324 (Commits) Commit: 87d03249071edf4b2907304f77093c8cd8849f0b
Dependencies: Stopgaps:

Description (last modified by ncohen)

A post on sage-support [1] reported that the subgraph_search functions ignored edge labels, while the doc apparently claims the opposite.

Indeed, the common terminology of "labelled copies" and "unlabelled copies" is pretty misleading with respect to actual labels on the edge/vertices of the graph. With this branch, I hope to make this mistake less likely.

Nathann

[1] https://groups.google.com/d/topic/sage-support/CTeSnBZN7Sc/discussion

Change History (11)

comment:1 Changed 4 years ago by ncohen

  • Branch set to public/18296
  • Commit set to 52ccff914d2f9e7836ab8cd36afe60724734e8b3
  • Status changed from new to needs_review

New commits:

52ccff9trac #18296: Emphasize that Graph.subgraph_search ignores edge labels

comment:2 Changed 4 years ago by ncohen

  • Description modified (diff)

comment:3 Changed 4 years ago by dcoudert

  • Status changed from needs_review to needs_work

aglgorithm -> algorithm

otherwise, the patch seems OK

comment:4 Changed 4 years ago by git

  • Commit changed from 52ccff914d2f9e7836ab8cd36afe60724734e8b3 to 4c944996e14eee4b5abb07e5f1f42124a3695ab6

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

4c94499trac #18296: Emphasize that Graph.subgraph_search ignores edge labels

comment:5 Changed 4 years ago by ncohen

  • Status changed from needs_work to needs_review

comment:6 Changed 4 years ago by dcoudert

  • Reviewers set to David Coudert
  • Status changed from needs_review to positive_review

For me the patch is good to go (install, doctest, docbuild, etc.). David.

comment:7 Changed 4 years ago by ncohen

Thanks !

comment:8 Changed 4 years ago by vbraun

  • Status changed from positive_review to needs_work

docbuild fails

comment:9 Changed 4 years ago by git

  • Commit changed from 4c944996e14eee4b5abb07e5f1f42124a3695ab6 to 87d03249071edf4b2907304f77093c8cd8849f0b

Branch pushed to git repo; I updated commit sha1. New commits:

93a1ecetrac #18296: Merged with 6.7.beta4
87d0324trac #18296: Broken doc

comment:10 Changed 4 years ago by ncohen

  • Status changed from needs_work to positive_review

I don't see how it was caused by this branch, but indeed there is a mistake O_o

comment:11 Changed 4 years ago by vbraun

  • Branch changed from public/18296 to 87d03249071edf4b2907304f77093c8cd8849f0b
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.