Opened 6 years ago

Closed 6 years ago

#18243 closed defect (duplicate)

Wrong result of NumberField.composite_field() when embeddings are specified

Reported by: pbruin Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords: number field compositum
Cc: Merged in:
Authors: Reviewers: Peter Bruin
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Reported on sage-support:

sage: nf = NumberField(x^8 - 3*x^7 + 61/3*x^6 - 9*x^5 + 298*x^4 + 458*x^3 + 1875*x^2 + 4293*x + 3099, 'z', embedding=-1.18126721294295 + 3.02858651117832j)
sage: nf2 = NumberField(x^8 - 3*x^7 + 61/3*x^6 - 9*x^5 + 298*x^4 + 458*x^3 + 1875*x^2 + 4293*x + 3099, 'z', embedding=-1.18126721294295 - 3.02858651117832j)
sage: nf.composite_fields(nf2, both_maps=True)
[(Number Field in z with defining polynomial x^8 - 3*x^7 + 61/3*x^6 - 9*x^5 + 298*x^4 + 458*x^3 + 1875*x^2 + 4293*x + 3099,
Ring endomorphism of Number Field in z with defining polynomial x^8 - 3*x^7 + 61/3*x^6 - 9*x^5 + 298*x^4 + 458*x^3 + 1875*x^2 + 4293*x + 3099
Defn: z |--> z,
Ring morphism:
From: Number Field in z with defining polynomial x^8 - 3*x^7 + 61/3*x^6 - 9*x^5 + 298*x^4 + 458*x^3 + 1875*x^2 + 4293*x + 3099
To: Number Field in z with defining polynomial x^8 - 3*x^7 + 61/3*x^6 - 9*x^5 + 298*x^4 + 458*x^3 + 1875*x^2 + 4293*x + 3099
Defn: z |--> z,
 +Infinity)]

The NumberField containing both (complex conjugate) embeddings should be larger.

The cause is probably that the defining polynomial f does not have integral coefficients. When f is replaced by QQ['x'](pari(f).polredabs()) (which is x^8 - x^7 + x^6 - 2*x^5 - x^4 + x^3 + x^2 + 2*x + 1), the result is a number field of degree 32.

Change History (5)

comment:1 Changed 6 years ago by pbruin

See also the prehistoric ticket #252...

comment:2 Changed 6 years ago by pbruin

  • Milestone changed from sage-6.7 to sage-duplicate/invalid/wontfix

This ticket is most likely a duplicate of #14164.

comment:3 Changed 6 years ago by pbruin

  • Reviewers set to Peter Bruin
  • Status changed from new to needs_review

comment:4 Changed 6 years ago by pbruin

  • Status changed from needs_review to positive_review

comment:5 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.