Opened 6 years ago

Closed 6 years ago

#18237 closed enhancement (fixed)

upgrade to pynac-0.3.5

Reported by: rws Owned by:
Priority: major Milestone: sage-6.7
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Ralf Stephan Reviewers: Benjamin Hackl
Report Upstream: N/A Work issues:
Branch: c5ac7dc (Commits, GitHub, GitLab) Commit: c5ac7dcca650cef95ed65cfb77c51b111fd80193
Dependencies: Stopgaps:

Status badges

Description

We skip 0.3.3 (#18155) which couldn't be used because of a bug showing on OSX.

https://drive.google.com/folderview?id=0B4PmRyK1JXgHfmJmbWZ5NnVtMnNITTVHQ2hCci1WVnhLbC1PeC1YbzRQLUpidU9yY0x3Qjg&usp=sharing

* fixed the series expansion of zeta(s) around 1
* print_latex of wildcards
* clear the libtool versioning scheme
* sync with current GiNaC as much as possible
* revert GiNaC commit interfering with Pynac print order
* fix code that produced warnings

Upgrade will require a few doctests to adapt, see https://groups.google.com/d/topic/sage-devel/hwQXxFmutcU/discussion

Dependent tickets: #15047, #15846

Change History (9)

comment:1 Changed 6 years ago by rws

  • Branch set to u/rws/pynac035

comment:2 Changed 6 years ago by rws

  • Authors set to Ralf Stephan
  • Commit set to c5ac7dcca650cef95ed65cfb77c51b111fd80193
  • Status changed from new to needs_review

New commits:

835d82bpynac-0.3.5
2db262118155: upgrade to pynac-0.3.3
216e29c18155: changed chksum for tarball made with make dist
839c49f18155: file change
c5ac7dcfix doctests

comment:3 Changed 6 years ago by behackl

On it, currently doing some more doctesting on Arch Linux (kernel 3.19.3-3, i7, 12GB RAM); will be finished soon.

Meanwhile: I can confirm that the bug with the unstable output of integrate(sec(x), (x, 0, pi/8)) on OSX (see https://github.com/pynac/pynac/issues/18) is gone. Thanks to Volker for access to the OSX buildslave!

comment:4 follow-up: Changed 6 years ago by behackl

MAKE="make -j4" make ptestlong gives

----------------------------------------------------------------------
sage -t --long --warn-long 81.8 src/sage/combinat/dyck_word.py  # 1 doctest failed
----------------------------------------------------------------------

The doctest fails with

sage -t --long --warn-long 81.8 src/sage/combinat/dyck_word.py
**********************************************************************
File "src/sage/combinat/dyck_word.py", line 3501, in sage.combinat.dyck_word.DyckWords_size.__init__
Failed example:
    TestSuite(DyckWords(4,2)).run()
Expected nothing
Got:
    Failure in _test_enumerated_set_iter_cardinality:
    Traceback (most recent call last):
      File "/home/behackl/Programming/sage-6.7.beta1/local/lib/python2.7/site-packages/sage/misc/sage_unittest.py", line 282, in run
        test_method(tester = tester)
      File "/home/behackl/Programming/sage-6.7.beta1/local/lib/python2.7/site-packages/sage/categories/finite_enumerated_sets.py", line 462, in _test_enumerated_set_iter_cardinality
        tester.assert_(isinstance(card, Integer))
      File "/home/behackl/Programming/sage-6.7.beta1/local/lib/python/unittest/case.py", line 422, in assertTrue
        raise self.failureException(msg)
    AssertionError: False is not true
    ------------------------------------------------------------
    The following tests failed: _test_enumerated_set_iter_cardinality
**********************************************************************
1 item had failures:
   1 of   2 in sage.combinat.dyck_word.DyckWords_size.__init__
    [574 tests, 1 failure, 2.98 s]

This happened two times. However, when testing the respective file manually:

sage -t --long --warn-long 81.8 src/sage/combinat/dyck_word.py
    [574 tests, 0.95 s]
----------------------------------------------------------------------
All tests passed!
----------------------------------------------------------------------

So this only seems to occur for make ptestlong.

Additionally, as I've not run make ptestlong on a clean install of 6.7.beta1 yet, I'm not even sure if this is related to Pynac at all. I'll do so and report back...

comment:5 Changed 6 years ago by behackl

See https://groups.google.com/forum/?fromgroups=#!topic/sage-devel/7BQPmEgfA8M -- until this is resolved, I can't review the new Pynac version reliably.

comment:6 in reply to: ↑ 4 Changed 6 years ago by jkeitel

I had the same doctest fail today on a clean 6.7beta1 install and, just like you, could not reproduce it when running this specific test again on the file, so I doubt that this is related to this ticket.

comment:7 Changed 6 years ago by behackl

I'm also quite sure that it has nothing to do with this ticket; especially after Vincent confirmed that this is happening for him too on both 6.7.beta0 and 6.7.beta1. This discussion, however, belongs to the sage-devel thread.

Still, I don't like the idea of giving this positive_review when I don't have a passing ptestlong, regardless of why the doctest is failing. Currently, I'm compiling sage on two more machines; one of those should enable me to review this.

comment:8 Changed 6 years ago by behackl

  • Reviewers set to Benjamin Hackl
  • Status changed from needs_review to positive_review

It seems that something went wrong when I upgraded sage from 6.6.rc2 to 6.7.beta1. Completely rebuilding sage resolves everything, and make ptestlong passes without problems again for both, the clean install as well as this ticket (on all three machines I tested this; 2x Arch Linux, 1x Linux Mint). Therefore: positive_review. :-)

Last edited 6 years ago by behackl (previous) (diff)

comment:9 Changed 6 years ago by vbraun

  • Branch changed from u/rws/pynac035 to c5ac7dcca650cef95ed65cfb77c51b111fd80193
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.