Opened 7 years ago

Closed 7 years ago

#18129 closed defect (duplicate)

Symbolic powers broken for complex numbers

Reported by: vdelecroix Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: tmonteil, gagern Merged in:
Authors: Reviewers: Thierry Monteil
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Taking fractional powers of symbolic terms is broken

sage: a = -1
sage: b = a^(1/3)
sage: b.n()       # determination of the third root
0.500000000000000 + 0.866025403784439*I
sage: b**2        # very bad
1

Because of that, it is dangerous to use symbolic expressions within QQbar as in #16222.

Change History (4)

comment:1 Changed 7 years ago by rws

sage: ((-1)^(1/3))
(-1)^(1/3)
sage: ((-1)^(2/3))
1

So it's apparently not the application of the power but the instant simplification by Pynac, if I'm not mistaken.

Version 1, edited 7 years ago by rws (previous) (next) (diff)

comment:2 Changed 7 years ago by tmonteil

  • Milestone changed from sage-6.6 to sage-duplicate/invalid/wontfix
  • Reviewers set to Thierry Monteil
  • Status changed from new to needs_review

This looks like a duplicate of #15605.

comment:3 Changed 7 years ago by rws

  • Status changed from needs_review to positive_review

comment:4 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.