Changes between Version 3 and Version 45 of Ticket #18128


Ignore:
Timestamp:
02/09/17 08:35:55 (5 years ago)
Author:
jipilab
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #18128

    • Property Status changed from needs_review to positive_review
    • Property Reviewers changed from to Vincent Delecroix, Frédéric Chapoton
    • Property Authors changed from to Jean-Philippe Labbé
    • Property Milestone changed from sage-6.6 to sage-7.6
    • Property Commit changed from 8bec9b2a593ea93e7ba49db17303565e82e29016 to 55f9cf6e235cd0a0d7d2b0158ab51423510b172d
  • Ticket #18128 – Description

    v3 v45  
    77Further, one can define a face truncation similarly with the same code. I am implementing a method called ".face_truncation(face, normal_coefficient, cut_frac)" taking a face of the polytope, and two optional parameters to vary the angle of the cut.
    88
    9 This new method makes the old method ill-named. It should be recalled simply "truncation" or "complete_vertex_truncation".
     9This new method makes the old method ill-named. It should be renamed simply "truncation" or "complete_vertex_truncation".
    1010
    1111While at it, I corrected a few writing conventions in the file.