Opened 6 years ago

Closed 6 years ago

#18105 closed defect (duplicate)

No conversion to CIF for some symbolic expression

Reported by: vdelecroix Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords: sd66
Cc: rws Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by vdelecroix)

sage: CIF(cos(2/3))
Traceback (most recent call last):
...
TypeError: unable to simplify to a complex interval approximation

The answer should just be

sage: CIF(RIF(cos(2/3)))
0.7858872607769480?

Change History (5)

comment:1 Changed 6 years ago by vdelecroix

  • Description modified (diff)
  • Summary changed from No coercion to CIF for some symbolic expression to No conversion to CIF for some symbolic expression

comment:2 Changed 6 years ago by vdelecroix

  • Cc rws added

comment:3 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-6.6 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #17285 I guess.

comment:4 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:5 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.