Opened 6 years ago

Closed 6 years ago

#18103 closed enhancement (duplicate)

cleanup number fields coerce embeddings

Reported by: vdelecroix Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords: sd66
Cc: sstarosta Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by vdelecroix)

This ticket is a duplication of #12715.

Currently, the default coerce embedding uses RLF/CLF but heavily relies on AA/QQbar. It is bad for several reasons:

  • there is no coercion from RLF/CLF to AA/QQbar
  • equality and comparisons in RLF are completely broken (because it relies on finite approximations)
    sage: K.<cbrt3> = NumberField(x^3 - 3, embedding=1)
    sage: b=(1+RLF(cbrt3))/2
    sage: c=1/2 + 3/2*(RLF(cbrt3)/3)
    sage: b == c
    False
    

In this ticket:

  • we get rid of RLF/CLF for number field embeddings and use AA/QQbar instead
  • we make the interaction between AA and number fields more friendly
  • we speed up a lot the approximations of number field elements using Cython

In a ticket #18104, we will consider number fields with complex embeddings.

Change History (5)

comment:1 Changed 6 years ago by vdelecroix

  • Dependencies set to #17830
  • Description modified (diff)
  • Keywords sd66 added

comment:2 follow-up: Changed 6 years ago by mmezzarobba

Looks like a duplicate of #5355 and #12715.

comment:3 in reply to: ↑ 2 Changed 6 years ago by vdelecroix

  • Dependencies #17830 deleted
  • Description modified (diff)
  • Milestone changed from sage-6.6 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Replying to mmezzarobba:

Looks like a duplicate of #5355 and #12715.

It is (of #12715). Could you close it?

I will add some details in #12715 (I have an implementation which works except for cyclotomic fields).

Vincent

comment:4 Changed 6 years ago by mmezzarobba

  • Status changed from needs_review to positive_review

comment:5 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.