Opened 6 years ago

Closed 6 years ago

#18060 closed enhancement (duplicate)

Palindromes, list of LPS lengths and list of maximal palindromes lengths

Reported by: nadialafreniere Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords: words, finite words, palindromes
Cc: slabbe, vdelecroix Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by nadialafreniere)

This is a new ticket for the algorithm I proposed in ticket #16935. The reason I create a new ticket for it is that there were modifications in the finite_word class (I did not know how to solve that problem otherwise). This aims to integrate the modifications already done by others in the class and the comments that have were written about ticket #16935.

Change History (9)

comment:1 Changed 6 years ago by nadialafreniere

  • Branch set to u/nadialafreniere/palindromes__list_of_lps_lengths_and_list_of_maximal_palindromes_lengths

comment:2 Changed 6 years ago by nadialafreniere

  • Authors set to Nadia Lafrenière
  • Branch u/nadialafreniere/palindromes__list_of_lps_lengths_and_list_of_maximal_palindromes_lengths deleted
  • Cc slabbe added
  • Component changed from PLEASE CHANGE to combinatorics
  • Description modified (diff)
  • Keywords words finite words palindromes added
  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to enhancement

comment:3 Changed 6 years ago by vdelecroix

  • Cc vdelecroix added

comment:4 Changed 6 years ago by vdelecroix

Bonsoir Nadia,

I do not quite understand why you opened this new ticket. Is it exactly the same purpose as for ticket #16935? Furtheromre, in this ticket there seems to be a problem with the branch field which does not appear in the ticket description.

Vincent

comment:5 Changed 6 years ago by nadialafreniere

  • Branch set to u/nadialafreniere/palindromes__list_of_lps_lengths_and_list_of_maximal_palindromes_lengths

comment:6 Changed 6 years ago by slabbe

  • Commit set to 160ccb0ccfb7580fe5d497b3b049fbf2b3c25523
  • Milestone changed from sage-6.6 to sage-duplicate/invalid/wontfix

This is a duplicate of #16935. Creating a new branch does not need the creation of a new ticket!


New commits:

160ccb0Initial commit

comment:7 Changed 6 years ago by git

  • Commit changed from 160ccb0ccfb7580fe5d497b3b049fbf2b3c25523 to d535b5f2f292d83d1dc952023dffe5506dd8f7f9

Branch pushed to git repo; I updated commit sha1. New commits:

67ac06fMerge branch 'u/nadialafreniere/palindromes...` into t/16935
ef438b5Improving length_maximal_palindrome method
d535b5fModified of lengths_maximal_palindromes to answer previous question, shortened palindromes function

comment:8 Changed 6 years ago by vdelecroix

  • Authors Nadia Lafrenière deleted
  • Branch u/nadialafreniere/palindromes__list_of_lps_lengths_and_list_of_maximal_palindromes_lengths deleted
  • Commit d535b5f2f292d83d1dc952023dffe5506dd8f7f9 deleted
  • Status changed from needs_review to positive_review

comment:9 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.