Opened 4 years ago

Closed 4 years ago

#18053 closed enhancement (duplicate)

Move all cython() functions in one place

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-6.6
Component: cython Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Currently we have

  • src/sage/misc/cython.py
  • src/sage/misc/cython_c.pyx
  • src/sage/server/support.py

which all contain Cython-related functions calling eachother in complicated ways.

As a first step towards a clean-up, move everything in one file.

Change History (1)

comment:1 Changed 4 years ago by jdemeyer

  • Authors Jeroen Demeyer deleted
  • Resolution set to duplicate
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to closed

Duplicate of #9552.

Note: See TracTickets for help on using tickets.