Opened 5 years ago

Closed 5 years ago

#17988 closed enhancement (duplicate)

Implement fully-packed loops (duplicate of 18003)

Reported by: jessicapalencia Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords: days64, asm, fpl
Cc: jamespropp, kdilks, egunawan, jcampbell, vinceknight, tscrim Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by egunawan)

This is a duplicate of Ticket 18003.

Implement fully-packed loops, based on the six vertex model already implemented.

Previously on branch u/vinceknight/fpl

Change History (14)

comment:1 Changed 5 years ago by kdilks

Current plan: Create fullypackedloop.py and class. Making underlying object the corresponding six vertex model. Add methods for ascii/graphical representation by modifying corresponding code for six vertex model. Add method in alternatingsignmatrix.py to map to fully packed loop.

For later: Add additional structure to FPLs so that the link pattern/non-crossing partition structure can be extracted.

comment:2 Changed 5 years ago by jcampbell

  • Authors set to James Campbell, Vince Knight, Jessica Striker, Kevin Dilks, Emily Gunawan

comment:3 Changed 5 years ago by jessicapalencia

  • Branch set to u/vinceknight/fpl
  • Cc tscrim added
  • Commit set to 12133131a63c04f65728bc1b6ab95d6afb2152e3
  • Status changed from new to needs_review

Last 10 new commits:

8955b4aAdding some more plots
d76344dcreates tests for ascii
8d343a8Merge branch 'u/jcampbell/fpl' of git://trac.sagemath.org/sage into 17988
d6c9546Have global documentation with reference of many faces
0af224dMerge branch 'u/jcampbell/fpl' of git://trac.sagemath.org/sage into 19788
9334f9eMerge branch 'u/jcampbell/fpl' of git://trac.sagemath.org/sage into 19788
6e15481to_fully_packed_loop methods
bdaeea3Fixing merge conflict and a test
8232ef7Tweak to the global class docs
1213313Changing reference

comment:4 Changed 5 years ago by vinceknight

Just commenting here that this patch includes images in the docs.

comment:5 Changed 5 years ago by vinceknight

Trying to reset the trac branch.

comment:6 Changed 5 years ago by vinceknight

  • Branch u/vinceknight/fpl deleted
  • Commit 12133131a63c04f65728bc1b6ab95d6afb2152e3 deleted

comment:7 Changed 5 years ago by vinceknight

  • Branch set to u/vinceknight/fpl
  • Commit set to 12133131a63c04f65728bc1b6ab95d6afb2152e3

Last 10 new commits:

8955b4aAdding some more plots
d76344dcreates tests for ascii
8d343a8Merge branch 'u/jcampbell/fpl' of git://trac.sagemath.org/sage into 17988
d6c9546Have global documentation with reference of many faces
0af224dMerge branch 'u/jcampbell/fpl' of git://trac.sagemath.org/sage into 19788
9334f9eMerge branch 'u/jcampbell/fpl' of git://trac.sagemath.org/sage into 19788
6e15481to_fully_packed_loop methods
bdaeea3Fixing merge conflict and a test
8232ef7Tweak to the global class docs
1213313Changing reference

comment:8 Changed 5 years ago by git

  • Commit changed from 12133131a63c04f65728bc1b6ab95d6afb2152e3 to e79daf953d9b7ed83725e879ea54d7c74d7a0810

Branch pushed to git repo; I updated commit sha1. New commits:

e79daf9Fixing merge conflict after #17977 got merged in to develop

comment:9 Changed 5 years ago by git

  • Commit changed from e79daf953d9b7ed83725e879ea54d7c74d7a0810 to 7e38bd9c39c66532d63a9e087533979dbb596277

Branch pushed to git repo; I updated commit sha1. New commits:

7e38bd9Fixing merge conflict and a minor relic in init doc

comment:10 Changed 5 years ago by egunawan

Since I was only involved in putting the method to_fully_packed_loop, I can be one of the reviewers. I think we should put the function eq so that we can test equality using "==". For example ...

sage: m=AlternatingSignMatrix?(1,0,0],[0,1,0],[0,0,1?) sage: m.to_fully_packed_loop() == FullyPackedLoop?(m) False sage: FullyPackedLoop?(m) == FullyPackedLoop?(m) False

comment:11 Changed 5 years ago by egunawan

  • Branch u/vinceknight/fpl deleted
  • Commit 7e38bd9c39c66532d63a9e087533979dbb596277 deleted
  • Description modified (diff)
  • Milestone changed from sage-6.6 to sage-duplicate/invalid/wontfix
  • Summary changed from Implement fully-packed loops to Implement fully-packed loops (duplicate of 18003)

comment:12 Changed 5 years ago by tscrim

  • Status changed from needs_review to positive_review

comment:13 Changed 5 years ago by tscrim

  • Authors James Campbell, Vince Knight, Jessica Striker, Kevin Dilks, Emily Gunawan deleted
  • Reviewers set to Travis Scrimshaw

Agreed; duplicate of #18003.

comment:14 Changed 5 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.