Opened 5 years ago

Closed 5 years ago

#17954 closed defect (fixed)

SyntaxError: from __future__ imports must occur at the beginning of the file

Reported by: jdemeyer Owned by:
Priority: blocker Milestone: sage-6.6
Component: scripts Keywords:
Cc: Merged in:
Authors: André Apitzsch Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: ca38582 (Commits) Commit: ca38582eb8634f43ca311b7ff0b5d7577a17709d
Dependencies: Stopgaps:

Description

  File "/usr/local/src/sage-git/local/bin/sage-CSI", line 15
    from __future__ import print_function
SyntaxError: from __future__ imports must occur at the beginning of the file

Change History (3)

comment:1 Changed 5 years ago by aapitzsch

  • Authors set to André Apitzsch
  • Branch set to u/aapitzsch/ticket/17954
  • Commit set to ca38582eb8634f43ca311b7ff0b5d7577a17709d
  • Status changed from new to needs_review

comment:2 Changed 5 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

comment:3 Changed 5 years ago by vbraun

  • Branch changed from u/aapitzsch/ticket/17954 to ca38582eb8634f43ca311b7ff0b5d7577a17709d
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.