Opened 5 years ago

Closed 3 years ago

#17879 closed defect (wontfix)

wrong ex.substitution of x*y

Reported by: rws Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

    sage: x,y = var('x,y')
    sage: f = x*y + x^2*y^2 + x*y^2
    sage: f.subs({x*y:u})
    x^2*y^2 + x*y^2 + u

This is from http://ask.sagemath.org/question/25972/substitute-xy-by-u/

It seems the current substitution system is not sophisticated enough to get the expected result.

Change History (3)

comment:1 Changed 3 years ago by rws

  • Milestone changed from sage-6.6 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

I think this is a duplicate of #18396.

comment:2 Changed 3 years ago by vdelecroix

  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to positive_review

It is!

comment:3 Changed 3 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.